Parted Magic display problem

Try looking for help here if you are having problems with the latest beta of Ultimate Boot CD.

Moderators: Icecube, StopSpazzing

Post Reply
Message
Author
NickH
Posts: 2
Joined: Thu Mar 06, 2014 5:09 am

Parted Magic display problem

#1 Post by NickH » Thu Mar 06, 2014 5:20 am

Hi,
I currently have UBCD 5.2.9 but have been using older versions for a while now but I've hit a problem.

I now have a brand new PC with a 4th Gen i3 Haswell processor and H87 motherboard (latest BIOS). When I try to run Parted Magic, it does not launch into the desktop, but to some sort of display configuration screen. If I try the Xorg menu option it disappears off for a while then comes back to the same menu. If I use XVesa, the desktop launched, but a couple of inches too high on the screen so I have a black screen under the task bar and I'm missing the top of the desktop so any app which opens on the desktop opens too high for me to be able to grab it and re-position it. I have no idea what to do now.

If it is any help, I also use a Linux distro called ClearOS. This has been booting OK with the grub option vga=0x314 on other systems but it does not work on this one and I had to change it to vga=792.

TIA,

Nick

ady
Posts: 826
Joined: Sat May 08, 2010 5:26 am

Re: Parted Magic display problem

#2 Post by ady » Thu Mar 06, 2014 10:21 pm

My guess is that you are booting this new system in UEFI mode. For UBCD, you need to set your firmware to CSM (aka. legacy BIOS compatibility mode). But, if you already have an OS booting in UEFI mode (e.g. Windows 8.x), you would need to go back to UEFI mode before rebooting back into that OS.

UBCD depends on BIOS.

Regarding the screen resolution modes, certain codes have changed for UEFI. In other words, UEFI uses some different methods to set the screen resolution. I am not saying this is your particular case, but it could be.

I would suggest trying a (recent) Linux distro that already supports UEFI. If such distro boots correctly in your new system (with correct graphics included), then you might find which video modes would be appropriate for this particular system.

NickH
Posts: 2
Joined: Thu Mar 06, 2014 5:09 am

Re: Parted Magic display problem

#3 Post by NickH » Fri Mar 07, 2014 12:56 am

My reply got eaten so I'll try again.

The BIOS is an UEFI BIOS but I have transplanted a 2TB MBR disk to it and it works fine so perhaps the BIOS is doing some sort of auto-detection.

I created a USB pen version of gparted using LinuxLive USB Creator and it worked fine. I've just tracked down a 2013-08-01 iso version of Parted Magic and put that on a USB pen with LinuxLive and it has the same problem so I assume it is a Parted Magic issue.

Since all I want for the moment is a partition manager, text editor and file manager, it looks like the gparted iso will do the job. I just liked having all the other utilities on one distro :(

dizpo
Posts: 4
Joined: Wed Nov 19, 2014 9:57 am

Re: Parted Magic display problem

#4 Post by dizpo » Wed Nov 19, 2014 12:03 pm

Same problem here :?

Victor Chew
Posts: 1359
Joined: Mon Feb 21, 2005 10:59 pm
Contact:

Re: Parted Magic display problem

#5 Post by Victor Chew » Wed Nov 19, 2014 5:05 pm

If you would like to try out a LiveCD that we've been working on (tentatively called "UBCD Live"):

viewtopic.php?p=25478#p25478

and provide feedback, that will be great.

Eventually, we will have to replace Parted Magic, and "UBCD Live" is a possible candidate if something better cannot be found.

dizpo
Posts: 4
Joined: Wed Nov 19, 2014 9:57 am

Re: Parted Magic display problem

#6 Post by dizpo » Wed Nov 19, 2014 7:28 pm

Victor Chew wrote:If you would like to try out a LiveCD that we've been working on (tentatively called "UBCD Live"):
...
and provide feedback, that will be great.
Hi Victor. Your link (UBCD Live) works like a charm. Now if only I could add parted magic to it and do a secure erase on several SSDs...

ady
Posts: 826
Joined: Sat May 08, 2010 5:26 am

Re: Parted Magic display problem

#7 Post by ady » Wed Nov 19, 2014 9:34 pm

dizpo wrote: Hi Victor. Your link (UBCD Live) works like a charm. Now if only I could add parted magic to it and do a secure erase on several SSDs...
You could buy the latest release of pmagic and get support there. Or you could search for the alternatives, your choice.

Victor Chew
Posts: 1359
Joined: Mon Feb 21, 2005 10:59 pm
Contact:

Re: Parted Magic display problem

#8 Post by Victor Chew » Wed Nov 19, 2014 11:54 pm

Now if only I could add parted magic to it and do a secure erase on several SSDs...
Which tool in Parted Magic do you use to do this?

dizpo
Posts: 4
Joined: Wed Nov 19, 2014 9:57 am

Re: Parted Magic display problem

#9 Post by dizpo » Thu Nov 20, 2014 4:32 pm

ady wrote:
dizpo wrote: Hi Victor. Your link (UBCD Live) works like a charm. Now if only I could add parted magic to it and do a secure erase on several SSDs...
You could buy the latest release of pmagic and get support there. Or you could search for the alternatives, your choice.
Ady, that's probably the best advice yet!

dizpo
Posts: 4
Joined: Wed Nov 19, 2014 9:57 am

Re: Parted Magic display problem

#10 Post by dizpo » Thu Nov 20, 2014 4:34 pm

Victor Chew wrote:
Now if only I could add parted magic to it and do a secure erase on several SSDs...
Which tool in Parted Magic do you use to do this?
There's a Secure Erase tool Victor. I use it all the time on my desktop, but the laptop has a Haswell CPU with both onboard and discrete GPUs, and the display is getting messed up with them somehow.

Post Reply