Ultimate Boot CD
http://www.ultimatebootcd.com/forums/

Syslinux when building USB stick
http://www.ultimatebootcd.com/forums/viewtopic.php?f=10&t=14812
Page 1 of 1

Author:  bmarsh [ Mon Feb 02, 2015 1:15 pm ]
Post subject:  Syslinux when building USB stick

I've been trying to build UBCD533 on a USB stick and have followed all the steps in the readme.txt. However, the final step of writing syslinux to the device just doesn't seem to be working and when I try to boot from the USB, I get a "missing operating system" message.

A couple of questions:

1) Should the USB stick remain mounted for that final step? There is no statement saying to unmount it. I've tried it both ways.

2) Should it be /dev/sdX1 or /dev/sysX? (changing X of course)

Whenever I run the syslinux command as mentioned in the last step, it says "no previous boot sector found" or close to that.

Any help would be appreciated.

Author:  ady [ Mon Feb 02, 2015 7:08 pm ]
Post subject:  Re: Syslinux when building USB stick

I assume you are talking about:
ubcd533.iso -> ./ubcd/tools/linux/ubcd2usb/readme.txt

In fact the steps are slightly inaccurate, and UBCD could include a script for this process (borrowing from GPartedLive/ClonezillaLive and adapting them for UBCD should be a first nice attempt).

Regarding the 'syslinux' command, it requires the relevant (destination) volume device to be UNmounted before executing the command, which means that you need the binary to be located elsewhere (too).

Regarding the destination device for the 'syslinux' command, it should be "
/dev/sdXN
" (it needs the partition too, "N", not just the "X"). I would suggest using the following options: "
-d /boot/syslinux -i /dev/sdXN
", where the "XN" should be replaced appropriately. Note that I am not using the "-s" parameter and that I am adding the "-i" parameter just before the destination device.

If you have a Windows system, the Windows-based "ubcd2usb.cmd" script should work correctly.

Author:  bmarsh [ Sun Feb 08, 2015 1:31 pm ]
Post subject:  Re: Syslinux when building USB stick

Thanks.... will give your changes a try. No windows here.. so your info is appreciated.

Page 1 of 1 All times are UTC - 8 hours
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/