Ultimate Boot CD
http://www.ultimatebootcd.com/forums/

FreeDOS does not detect my dvd drive, all apps are missing
http://www.ultimatebootcd.com/forums/viewtopic.php?f=10&t=2420
Page 1 of 1

Author:  bugblatter [ Mon May 31, 2010 7:30 pm ]
Post subject:  FreeDOS does not detect my dvd drive, all apps are missing

First, I ran ubcd v4.11 (same computer, same drive) from cd and dvd, and everything seemed to work fine.

Second, if I run v5.01 from usb flash drive, everything seems to work.

But if I run v5.01 from cd or dvd, everything except any FreeDOS stuff works. The FreeDOS menu eventually shows up but clicking 'Launch' does not list the available apps. Meanwhile it complains the CD-ROM drive is missing.

The 'drd' command shows no active drives (all invalid) except:
A: writable (memdisk fake writable)
Q: writable

I searched the forum and found this:
viewtopic.php?t=2191

I downloaded ubcd50RC1_dos.iso and put it in custom.
I edited custom.cfg to add:
Code:
LABEL ubcd50RC1dos
MENU LABEL Boot DOS apps of UBCD50RC1
LINUX /boot/syslinux/memdisk-iso
INITRD /ubcd/custom/ubcd50RC1_dos.iso
APPEND iso raw


I edited custom.lst to add:
Code:
title Boot DOS apps of UBCD50RC1
map /boot/ubcd/ubcd50RC1_dos.iso (hd33) || map --mem /boot/ubcd/ubcd50RC1_dos.iso (hd33)
map --hook
map --mem (hd33)/ubcd/images/fdubcd.img.gz (fd0)
map --hook
root (fd0)
chainloader (fd0)+1


No luck, but I think I got an error message when I tried grub4dos, which complained about not finding /boot/ubcd/ubcd50RC1_dos.iso, so I copied it there too. No error message, but still didn't find my dvd drive. I imagine these v5.0RC instructions might not apply to v5.01 though.

Any suggestions? Thanks.

Author:  StopSpazzing [ Mon May 31, 2010 8:56 pm ]
Post subject:  Re: FreeDOS does not detect my dvd drive, all apps are missi

bugblatter wrote:
I downloaded ubcd50RC1_dos.iso and put it in custom.
I edited custom.cfg to add:
...
INITRD /ubcd/custom/ubcd50RC1_dos.iso
...

I edited custom.lst to add:
...
map /boot/ubcd/ubcd50RC1_dos.iso (hd33) || map --mem /boot/ubcd/ubcd50RC1_dos.iso (hd33)
...


You arent pointing to the incorrect ISO location...check what I bolded above.
/ubcd/custom/ubcd50RC1_dos.iso is the location to the dos image, that's why it was giving an error in grub4dos.

As to the reason why its not loading properly, I'm unsure. Icecube would be the person to help you with this, I'm sure he will post on this topic soon.

Author:  Icecube [ Tue Jun 01, 2010 2:18 am ]
Post subject: 

Try this:
Quote:
LABEL ubcd50RC1dos
MENU LABEL Boot DOS apps of UBCD50RC1
LINUX /boot/syslinux/memdisk
INITRD /ubcd/custom/ubcd50RC1_dos.iso
APPEND iso raw


/boot/syslinux/memdisk-iso doesn't exist anymore in UBCD501.

Author:  bugblatter [ Tue Jun 01, 2010 12:39 pm ]
Post subject: 

StopSpazzing: I did catch that grub4dos path error right after I did it, but thanks anyway.

Icecube: Removing "-iso" from the memdisk line did the trick, thanks.

One more question: Is there any way to adapt this method to include our own dosapps? I mean the ones we normally add ourselves in custom.ini and custom.cfg. Or do we just wait for the next release? Edit: I'm going to try inject it into icecube's iso (I hear I'm supposed to use mkisofs) for now.

Thanks guys for your help.

Author:  bugblatter [ Wed Jun 02, 2010 10:24 pm ]
Post subject: 

Just an update: I was able to add my own dosapp to the ubcd50RC1_dos.iso (also edited its ubcd.ini) using mkisofs. Worked like a charm. Thanks.

Page 1 of 1 All times are UTC - 8 hours
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/