Page 1 of 1

v2.1 boots from all machines; v3.33 boots from some.

Posted: Mon May 30, 2005 2:08 pm
by der moyn
Hi guys
As the subject suggests: ubcd 2.1 will boot on both my laptop and desktop. However, ubcd 3.33, while booting fine on the desktop, refuses to boot on the laptop.

So, in a nutshell, what's the difference between the 2 versions? Booting-wise, as it were. I've trawled previous msgs but found nothing. Google does not help.

I've also tried the following:
Burning the iso at different speeds ranging from 2x upwards. Changing the types of blanks that I use. Burning on the laptop from 2x to 8x.

I've finally resorted to trying to customise the 2.1 and updating with the programs from 3.33. That procedure has got me somewhere. But it is surely the hard way and costly in CD blanks. e.g just finding out that F11 (and upwards?) does not work cost me a CD blank. My writer does not detect CD-RWs!

Also, getting my Acronis stuff to iso's and then trying to get them to work with 2.1 has defeated me. They work fine on the 3.33 with the desktop.
Everything works fine with the 3.33. Beautiful piece of work, by the way.

So, recapping a bit, rather than having to learn how to customize 2.1 I'd rather know is there something I can copy from 2.1 (boot.catalog or something?) and stick it on 3.33?

The laptop by the way is a DELL. And its one of those ones where you swap over the floppy with the CD ROM drive.

As I said, Ive tried a lot of things but I still end up back wondering why version 2.1 will boot from both machines? But 3.33 won't. Makes me think it can't be a hardware problem.

Appreciate any suggestions.


Posted: Mon May 30, 2005 8:01 pm
by Victor Chew
Is it possible to post some hardware details + error messages? For example:


has done pretty well.

For UBCD 2.2, you can't really boot an Acronis ISO images directly. You need to extract the WBT file using WinISO, and boot the WBT file using bcdw. Wait... was bcdw even included in that release? :D Can't remember.. too longer ago.

But if you have some time, I think it will be really worth your while if we try to solve this problem so you can run UBCD V3.3 on your laptop. Not to mention booting Acronis ISO images is so easy!

v2.1 (& 3.2)boots from all machines; v3.33 boots from so

Posted: Tue May 31, 2005 10:23 am
by der moyn
Thanks Victor, appreciate your time and effort.
Is it possible to post some hardware details + error messages?
Sure, should have done it earlier. But I was thinking that since 2.1 would boot the issue is most likely a software one.

Laptop Hardware details:

CPU: 750MHz Intel Mobile Pentium III (Coppermine)
Product Name: DELL Latitude CPx J750GT (Laptop)
RAM: 192MB
Onboard Video: ATI Mobility M1
Hard Disk 16.89GB (FUJITSU MHJ2181AT)

Desktop Hardware details:

CPU: Athlon XP 2800+
RAM 512MB DDR SDRAM (Crucial)
Motherboard: ASROCK K7S8XE+
AGP Graphics Card: nVidia GeForce2 MX/MX400 (Siluro)
Hard Disks: 80GB Maxtor (6YOLO80)
40GB Western Digital (Caviar)

Error message:

"Error booting from CD/DVD drive.
Press any key to reboot..."

At the bottom of the screen it has a long line of small boxes
(coloured in in white) and at the very end of that line it has the figures

A reboot or a cold boot give the same msg.

That's the last thing I see on the screen. I never get to the ubcd main menu.

Doing a search on Google brought back one hit - took me to the CD Forum. But not to the message. Doing a search over there produced no results. Am slowly trawling through their messages.

To facilitate troubleshooting this I thought it might be helpful if we knew which version of UBCD this problem started with. So, I downloaded versions 3.0, 3.1 and 3.2. All Basic (to save time). V2.1 is really too old and too many versions back to tell us much.
The problem seems to have started with v3.3 because v3.2 works on both the laptop and the desktop. (I've attempted to amend this threads subject line accordingly - makes it more useful to others).
The fact that the problem has started relatively recently has me wondering whether you made any major alterations between v3.2
and v3.3.

On that thread that you sent you mentioned to somebody:
If you have the time, could you try UBCD 3.2 on both machines and let us know how that goes? I am trying to isolate the problem and see
whether it's due to the latest version of CDShell we're using.
I have not made CDs of versions 3.1 or 3.0 as it didn't strike me that there was anything to be gained from doing so. If you see merit in it let me know.

By the way the problem exists with both versions of 3.33 - Basic and Full.

I can put some time into this so let me know what you want.

Many thanks.

Posted: Tue May 31, 2005 7:36 pm
by Victor Chew
Thanks for the detailed reply.

The CDShell forum is down at the moment, so I cannot check whether someone has replied. But the most major change with UBCD V3.3 is that we upgraded to CDShell 2.0.16 (V3.2 was using CDShell V2.0.11), with all the associated changes to isolinux, memdisk, diskemu, bcdw etc.

This sounds like a CDShell problem, so I am going to pursue in this direction and check with its maintainers to see whether we can fix these problems. Meanwhile, if you don't need ISO booting, you can actually backport most of the apps back to CDShell V2.0.11 quite easily I think.

Posted: Tue May 31, 2005 8:01 pm
by Victor Chew
Another idea just hit me. Some of the options used to create the UBCD violates the ISO9660 standard slightly. I was wondering if turning them off may help?

Currently, UBCD V3.3 is created using:

Code: Select all

mkisofs -N -J -D -r -o \ubcd.iso -b boot/loader.bin -no-emu l-boot -boot-load-size 4  .
The "-N' and "-D" switches are suspect because:

Code: Select all

-N Omit version numbers from ISO9660 file names. This violates the ISO9660 standard, but no one really uses the version numbers anyway. Use with caution.

Code: Select all

-D Do not use deep directory relocation, and instead just pack them in the way we see them. If ISO9660:1999 has not been selected, this violates the ISO9660 standard, but it happens to work on many systems. Use with caution.
I have created a skeletal test ISO image for this purpose. Do you think you could test it please?

Size: < 2MB
MD5: 2b3c7c04aa4b64bb4ead5d6679a99918


v2.1 boots from all machines; v3.33 boots from some.

Posted: Wed Jun 01, 2005 9:07 am
by bldrdash
> Another idea just hit me. Some of the options used to create
> the UBCD violates the ISO9660 standard slightly. I was
> wondering if turning them off may help?
> Currently, UBCD V3.3 is created using:
> mkisofs -N -J -D -r -o ubcd.iso -b boot/loader.bin -no-emu
> l-boot -boot-load-size 4&nbsp; .
> The "-N' and "-D" switches are suspect because:

I have used -N for a couple of years without problems. It is
only necessary when adding a "WinPE" environment to your UBCD,
which most don't, so can be omitted if you like.

-- Charles

Posted: Wed Jun 01, 2005 10:40 am
by der moyn
Hi Victor

First of all the bad news (good news down below!):
I wasn't quite sure how to test that " skeletal test ISO image" so I tried burning it to a CD with Nero but got a bundle of error messages while trying to do that:
07:38:18 #18 TRANSFER -18 File ThreadedTransferInterface.cpp, Line 1713
Could not perform EndTrack

07:38:18 #19 Text 0 File Mmc.cpp, Line 13141
<PLEXTOR CD-R PX-W2410A> start Close Session

07:38:18 #20 SCSI -1026 File Cdrdrv.cpp, Line 1151
SCSI Exec, HA 1, TA 0, LUN 0
Status: 0x04 (0x01, SCSI_ERR)
HA-Status 0x00 (0x00, OK)
TA-Status 0x02 (0x01, SCSI_TASTATUS_CHKCOND)
Sense Code: 0x2C
Sense Qual: 0x04
CDB Data: 0x5B 0x01 0x02 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00
Sense Data: 0x70 0x00 0x05 0x00 0x00 0x00 0x00 0x0A
0x00 0x00 0x00 0x00 0x2C 0x04

07:38:18 #21 CDR -1026 File WriterStatus.cpp, Line 230
Current program area empty

07:38:18 #22 TRANSFER -19 File WriterStatus.cpp, Line 230
Could not perform Fixation

07:38:18 #23 Text 0 File WriterStatus.cpp, Line 239
falling back to disc fixation

07:38:18 #24 Text 0 File dlgbrnst.cpp, Line 1678
Set remaining time: 0:00,000 (0ms) -> OK

07:38:18 #25 Phase 38 File dlgbrnst.cpp, Line 1818
Burn process failed at 4x (600 KB/s)
The resultant CD wouldn't boot on either PC.

Now for the good news:
I tried it with VMware from a virtual PC and while having it boot from the iso on the hard drive it worked on both the Desktop and the Laptop!!

So, I don't know what you have done but this is the first time I have had the v3.3 menu visible on my laptop. And was able to move between the different options.

Whether that needs to be qualified by the fact that it was within VMware or not I have no idea.

Maybe you'd better recommend a way for me to test that 'skeletal test image iso' if you have any reservations about VMware. I know little about VMware. Took me all day to figure it out. Not sure I've done it properly, but the fact that the v3.3 menu even appeared surely indicates something good. I reckon.

I suppose the real test would be to have it boot from a CD?

Anyway, thinks are looking up!!

By the way - not sure if this is relevant, but - I know nothing about mkisofs - so I've been using that batch file, build.bat:

Code: Select all

 mkisofs -N -J -D -r -o \ubcd.iso -b boot/loader.bin -no-emul-boot -boot-load-size 4 .
All the best

Posted: Wed Jun 01, 2005 12:45 pm
by der moyn
Hi guys
Regarding my previous post - I've ran a few tests here and my initial optimism about the results as achieved via VMware seems to have been quite unfounded.

I decided to see how reliable that earlier result was by copying the ubcd33-basic.iso to a usb stick and booting via VMware's virtual PC on the laptop. That, by the way, is the iso which when burnt to a CD by Nero would not boot the laptop. Well, the bad news (maybe?) is that VMware's virtual PC booted it. I then tried to have VMware's virtual PC boot from the actual CD that would not boot the laptop and that too booted from within the virtual PC!

So, that would seem to indicate that the jury is still out on whether or not that skeleton iso image works.
Got to get that to a CD. Not sure how to do that, now that Nero objects to it. Suggestions?

Apologies for my earlier precipitate assumptions. VMware's enthusiasm for booting everthing thrown at it took me quite unawares.


Posted: Wed Jun 01, 2005 4:49 pm
by der moyn
Eventually managed to burn that skeleton ubcd iso (with UltraIso) to CD and while it boots okay into Desktop it won't boot on the laptop giving the usual error message.

Posted: Thu Jun 02, 2005 8:01 pm
by Victor Chew
Could you check out my latest replies at:


and carry on our conversation there? I think we have the same general problem, so we should focus our discussion on one topic until the issue is resolved.