Page 1 of 1

TestDisk (check/undelete)

Posted: Mon Mar 16, 2009 8:50 pm
by dialac
I don't know whether this is the right place to ask this but,
currently im facing a problem and need assistant.
What happens is that i accidently cleared my MBR by writing zero bytes into it and if im not wrong,my partition table r deleted in the process too. Thus my pc is unable to start up everytime. Problem is, after burning ubcd411 into a cd and insert it into my pc, i go to filesystem tools>paratition tools>and enter testdisk, a list of words scrolls down and ends with InitDisk. It stucked at InitDisk for few hours already and nothin happens afterwards. Hope someone could give me a solution ASAP i've burnt the ubcd 4 times already and the same thing just happens :cry: :cry: :cry: :cry: :cry:

Posted: Tue Mar 17, 2009 2:45 am
by Icecube
Try UBCD50b12.
Testdisk is included in Parted Magic and not in the freedos image anymore.

Try also if the Freedos image of UBCD50b12 boots correctly. If not, describe the problem.

Posted: Tue Mar 17, 2009 6:02 am
by dialac
Alas,when i inserted the pen drive with parted magic, a black screen on my pc turned out and says 'no bootable partition in table'. Im sure i did double clicked on the syslinux to enable it to run in USB. :cry: :cry:

Posted: Tue Mar 17, 2009 6:12 am
by Icecube
Did you run the /ubcd/tools/win32/ubcd2usb/ubcd2usb.cmd script from your hard drive and did you give the right info to it to install it on the correct drive?

Posted: Tue Mar 17, 2009 6:15 am
by dialac
Oh no not that,im still downloading ubcd my connection 2day is quite laggy. Im using parted magic on pen drive jst now and it didn't worked out.

Posted: Tue Mar 17, 2009 6:31 am
by Icecube
You need to install the syslinux bootloader to your drive yourself in that case.

Download syslinux from:

Search syslinux.exe in the extracted archive.

Run syslinux.exe (adapt the path to syslinux.exe to the right one) from the command prompt (Run as.. ==> "cmd.exe"):

Code: Select all

C:\syslinux\syslinux.exe -ma -d /boot/syslinux/ X:
Change X: to the correct letter for your USB thumb drive.

Posted: Tue Mar 17, 2009 10:24 am
by dialac
hmm,finally running parted magic but once i get in there i couldn't find any keywords that says 'solve mbr/partition table' so i pressed the memtest86...thx alot icecube u saved part of my life :roll: now i need your guidance to the next step of solving my issue using parted magic :roll:

Posted: Tue Mar 17, 2009 10:51 am
by Icecube
You need to boot Parted Magic and select Testdisk in the start menu afterwards.

For help with testdisk:

Posted: Tue Mar 17, 2009 11:00 pm
by dialac
Partially solved, now im able to use testdisk thanks a bunch to icecube.
However, much of the help on the link u sent me doesn't seem to appeal my intention. My knowledge of these things are very limited, perhaps nil. Once again i request your step-by-step guide to recover the messed up situation in my pc.

Everything is fine but the partition table are jumbled in one piece,lol.

BEFORE: I accidently did this, in menu section, Delete>clear MBR partition table by writing zero bytes to it?>Y>Y>couldn't open the pc(a DHCP thingy loaded and some PXE error appears, requires me to restart the pc and the same process repeats)

NOW: Wierd, there's only one hard disk (500GB) to be selected which in truth i have 3 hard disk (52GB,208GB,208GB), in menu section, Analyse>Quick Search>N(for vista)>there's 3 over here>Deeper Search> voila there's about 6 poped-out with 5 of them in the alphabet D(delete) and the last one is marked with *(primary boot). My primary boot should be aligned to the 52GB hard disk, instead is located on one of the 208GB hard drive now.

Icecube, pls teach me what to do starting from the menu option by using arrows to indicate next step etc. :( :( :(

Posted: Wed Mar 18, 2009 1:18 am
by Icecube
Testdisk should list all your hard drives (see previous link: Disk selection).
Wierd, there's only one hard disk (500GB) to be selected which in truth i have 3 hard disk (52GB,208GB,208GB)
You have only one hard disk, which is partitioned in 3 or 4 (if you have a extended partition) partitions.

Can you post the output of the different search methods?

So if I understand you correctly, the 52 Gb is your Windows partition. Which Windows version do you have?

Did you repartition your hard drive some while ago (or someone else)?

Posted: Wed Mar 18, 2009 1:35 am
by dialac
Windows SP 2

Im not sure i did or not but im simply creating MBR and doing some deeper search then mess around with the partition type (primary boot the 52GB partition, the other 2 can only be primary/delete so i choose primary) and mess around with other partitioning tools.

Well i hope that won't worsen the situation :(

Posted: Thu Mar 19, 2009 5:53 am
by StopSpazzing
So, your only issue right now is no MBR correct? Well if you still have a vista dvd (not oem installed) put it in your drive and do a repair then there should be an option to reinstall bootloader...that should fix the MBR. Ive only used it once...but Im sure it will fix the MBR aswell as reinstall the bootloader so it starts up properly.