It is currently Fri Oct 24, 2014 2:19 am

All times are UTC - 8 hours




Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 15 posts ] 
Author Message
 Post subject: Adding background pic to UBCD?
PostPosted: Tue Sep 01, 2009 4:36 pm 
Offline

Joined: Fri Mar 14, 2008 12:05 pm
Posts: 46
Location: United States
so id like to add a background image to my current 4.xx build and i downloaded 5.0 to see how it was done..(their is alot that has gone into my custom build so id rather not do a total UG) and iv added the vesa menu updated iso and sys linux etc. here is the cide i have in my main.cfg

Code:
MENU INCLUDE /menus/defaults.cfg
DEFAULT /boot/syslinux/vesamenu.c32
MENU BACKGROUND /Image/splash.jpg


however with this code nothing appears any ideas?


Top
 Profile  
 
 Post subject:
PostPosted: Wed Sep 02, 2009 4:04 am 
Offline

Joined: Fri Jan 11, 2008 2:52 pm
Posts: 1278
From the Syslinux documentation:
Code:
MENU BACKGROUND background

   For vesamenu.c32, sets the background image.  The background
   can either be a color (see MENU COLOR) or the name of an image
   file, which should be 640x480 pixels and either in PNG or JPEG
   format.

You better use the newer syslinux syntax:
Code:
MENU INCLUDE /menus/defaults.cfg
UI /boot/syslinux/vesamenu.c32
MENU BACKGROUND /Image/splash.jpg

You also need to update all files (isolinux.bin, *.c32 and syslinux.exe). Install SYSLINUX again, when you run it from an USB drive.

_________________
Download Ultimate Boot CD v5.0: http://www.ultimatebootcd.com/download.html
Use Parted Magic for handling all partitioning task: http://partedmagic.com/


Top
 Profile  
 
 Post subject:
PostPosted: Wed Sep 02, 2009 10:32 am 
Offline

Joined: Fri Mar 14, 2008 12:05 pm
Posts: 46
Location: United States
all right i just did the upgrades to iso and syslinux thanks ill give it a go and let you know how it turns out :)


Top
 Profile  
 
 Post subject:
PostPosted: Wed Sep 02, 2009 11:14 am 
Offline

Joined: Fri Mar 14, 2008 12:05 pm
Posts: 46
Location: United States
hmmm i added it to my defaults.cfg because i want it displayed on all pages however it doesnt work. my defaults.cfg contains the following and all menus call off of it.

Code:
UI /syslinux/vesamenu.c32
MENU BACKGROUND /image/splash.png
MENU MARGIN 0
MENU ROWS -9
MENU TABMSG
MENU TABMSGROW -3
MENU CMDLINEROW -3
MENU HELPMSGROW -4
MENU HELPMSGENDROW -1

MENU COLOR SCREEN 44;37
MENU COLOR BORDER 44;37
MENU COLOR TITLE 1;44;37
MENU COLOR SCROLLBAR 44;37
MENU COLOR UNSEL 44;37
MENU COLOR SEL 7;44;37
MENU COLOR UNSEL 44;37
MENU COLOR CMDMARK 44;37
MENU COLOR CMDLINE 44;37
MENU COLOR TABMSG 44;37
MENU COLOR DISABLED 44;37
MENU COLOR HELP 44;37


i removed "menu color screen" to see if it was over riding but it got me noware. any ideas?


Top
 Profile  
 
 Post subject:
PostPosted: Wed Sep 02, 2009 11:44 am 
Offline

Joined: Fri Jan 11, 2008 2:52 pm
Posts: 1278
Does your picture has a resolution of 640x480 pixels?

_________________
Download Ultimate Boot CD v5.0: http://www.ultimatebootcd.com/download.html
Use Parted Magic for handling all partitioning task: http://partedmagic.com/


Top
 Profile  
 
 Post subject:
PostPosted: Wed Sep 02, 2009 6:33 pm 
Offline

Joined: Fri Mar 14, 2008 12:05 pm
Posts: 46
Location: United States
yes sir in .png format.


Top
 Profile  
 
 Post subject:
PostPosted: Thu Sep 03, 2009 6:08 am 
Offline

Joined: Fri Jan 11, 2008 2:52 pm
Posts: 1278
Can you upload the picture, so I can test it?

_________________
Download Ultimate Boot CD v5.0: http://www.ultimatebootcd.com/download.html
Use Parted Magic for handling all partitioning task: http://partedmagic.com/


Top
 Profile  
 
 Post subject:
PostPosted: Thu Sep 03, 2009 10:43 am 
Offline

Joined: Fri Mar 14, 2008 12:05 pm
Posts: 46
Location: United States
ya sure i couldnt figure out how to do it on these forums but here is were i uploaded it to. I really thank you for helping me out. getting this picture or any picture for that matter to work is a must for me.

http://www.solarisutilitydvd.com/img/splash.png


Top
 Profile  
 
 Post subject:
PostPosted: Thu Sep 03, 2009 11:18 am 
Offline

Joined: Fri Jan 11, 2008 2:52 pm
Posts: 1278
/isolinux/isolinux.cfg:
Code:
DISPLAY startup.msg
PROMPT 1
TIMEOUT 100
TOTALTIMEOUT 100

DEFAULT main
ONTIMEOUT boot

LABEL boot
LOCALBOOT -1

LABEL main
KERNEL vesamenu.c32
APPEND /menus/main.cfg

Relevant part of /syslinux/sylinux.cfg:
Code:
LABEL main
  KERNEL vesamenu.c32
  APPEND /menus/main.cfg

/menus/defaults.cfg
Code:
MENU BACKGROUND /image/splash.png

MENU MARGIN 0
MENU ROWS -9
MENU TABMSG
MENU TABMSGROW -3
MENU CMDLINEROW -3
MENU HELPMSGROW -4
MENU HELPMSGENDROW -1

MENU COLOR SCREEN 44;37
MENU COLOR BORDER 44;37
MENU COLOR TITLE 1;44;37
MENU COLOR SCROLLBAR 44;37
MENU COLOR UNSEL 44;37
MENU COLOR SEL 7;44;37
MENU COLOR UNSEL 44;37
MENU COLOR CMDMARK 44;37
MENU COLOR CMDLINE 44;37
MENU COLOR TABMSG 44;37
MENU COLOR DISABLED 44;37
MENU COLOR HELP 44;37


All otherconfig files in /menus/ should start with:
Code:
UI vesamenu.c32
MENU INCLUDE /menus/defaults.cfg

Also change menu.c32 to vesamenu.c32 in these files:
Code:
KERNEL vesamenu.c32
APPEND /menus/system.cfg

This works fine for me.

_________________
Download Ultimate Boot CD v5.0: http://www.ultimatebootcd.com/download.html
Use Parted Magic for handling all partitioning task: http://partedmagic.com/


Last edited by Icecube on Thu Sep 03, 2009 12:31 pm, edited 1 time in total.

Top
 Profile  
 
 Post subject:
PostPosted: Thu Sep 03, 2009 11:32 am 
Offline

Joined: Fri Mar 14, 2008 12:05 pm
Posts: 46
Location: United States
ok the isolinux.cfg and syslinux.cfg in the isolinux and syslinux folders didnt have vesamenu.c32 it was still menu.c32 ill give it a run now. thanks for the help ill get back to you. :) i really appreciate it.


Top
 Profile  
 
 Post subject:
PostPosted: Thu Sep 03, 2009 12:14 pm 
Offline

Joined: Fri Mar 14, 2008 12:05 pm
Posts: 46
Location: United States
hmm well it works kinda i have a preboot.cfg with a disclamer and the pic shows up their. but non of the other menus will display it. using the lines you provided. which is odd as they all read off of default.cfg so their shopuldnt be a problem?

Quote:
Also change menu.c32 to vesamenu.c32 in these files:

Code:
KERNEL vesamenu.c32
APPEND /ubcd/menus/system.cfg



and i cant find that i dont have a system.cfg


Top
 Profile  
 
 Post subject:
PostPosted: Thu Sep 03, 2009 12:30 pm 
Offline

Joined: Fri Jan 11, 2008 2:52 pm
Posts: 1278
It probably needs to be:
Code:
KERNEL vesamenu.c32
APPEND /menus/system.cfg

I don't have UBCD411 anymore, only UBCD50b*. In this version /menus/ is moved to /ubcd/menus/. Almost all files and directories that don't need to be in root are moved to the subdir /ubcd/ so it doesn't look to bad when you put UBCD on an USB stick and you want to use it for other things too.

Updated previous post, so try it again (remove /ubcd in the config files you have now).

_________________
Download Ultimate Boot CD v5.0: http://www.ultimatebootcd.com/download.html
Use Parted Magic for handling all partitioning task: http://partedmagic.com/


Top
 Profile  
 
 Post subject:
PostPosted: Thu Sep 03, 2009 11:55 pm 
Offline

Joined: Fri Mar 14, 2008 12:05 pm
Posts: 46
Location: United States
i wish their was a thanks system on the forums you sir have solved my problem and here is how i did it.


you see in the iso/sys linux.cfg files i have it appending not to "main" but to a "preboot" .cfg file. This file had a disclaimer about how powerfull the tools were etc. and had an "AGREE" or "DISAGREE" selection item. disagree booted hdd 1 agree appended main.cfg...and thats is were i found my problem. it appended menu.c32 i changed it to vesamenu.c32 and whalla main.cfg now showed a background. however it was pure white...so i had to add these lines to the beginning of every menu to get them to work properly.

Code:
UI /isolinux/vesamenu.c32
MENU INCLUDE /menus/default.cfg
MENU BACKGROUND /image/splash.png


after that it all worked properly..however when i selected "back" to go back to the previous menus i was running into curruption problems. i cured this by re-reading everything you said. and relized i had to re name everything menu related that was menu.c32 to vesamenu.c32 after i did this it all works now :D thanks a bunch icecube youve been a real help and have lit the path on learning the more complicated commands behind this stuff.


Top
 Profile  
 
 Post subject:
PostPosted: Tue Sep 08, 2009 3:43 am 
Offline

Joined: Tue Sep 08, 2009 3:37 am
Posts: 3
Hi Solaris17,

It is really seem very intersting , but I don't know much about it . If u know from your resources then let me know.

Thanks in advance.


Top
 Profile  
 
 Post subject:
PostPosted: Tue Sep 08, 2009 11:22 am 
Offline

Joined: Fri Mar 14, 2008 12:05 pm
Posts: 46
Location: United States
well we got it tow ork so if u need help with t we can help


Top
 Profile  
 
Display posts from previous:  Sort by  
Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 15 posts ] 

All times are UTC - 8 hours


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group