Page 1 of 1

How Do you create a M$Dos UBCD compatible "expert"

Posted: Fri Mar 31, 2006 7:14 pm
by freeballer
I've downloaded a bootdisk of msdos v6.22 off the net with cdrom drivers off the net... works perfectly by itself through memdisk but I want to be able to use it by ubcd's expert mode and add my own programs like ntfspro, and a few compression tools, ntfspro, etc...
I renamed the file to msubcd.img (of course) and then copied from freedos image and edited my autoexec to include:

Code: Select all

rem ---- BCDW ----
if not exist goto _bcdw
bcdw CheckForBCDW
if errorlevel 1 goto _bcdw
bcdw FindBootableCDLetter
if errorlevel 1 goto _bcdw
bcdw GetBootImageCommandLine
if errorlevel 1 goto _bcdw
if "%cd1%"=="" set cd1=%BCDW_CDROM%:
set ubcdcmd=%BCDW_CL%
then used to boot

Code: Select all

..... then isolinux memdisk initrd=/images/msubcd.img ubcdcmd=ntfs

Code: Select all

cd \dosapps\ntfs

Code: Select all

again, the disk boots fine but after i loads the cdrom drivers it stoped and I'm dropped to command line without errors. I've tried just about everything found on the post above too and nothing has worked..
What am I doing wrong?

Posted: Sat Apr 01, 2006 5:49 am
by Victor Chew
Erwin has a MS-DOS version of fdubcd.img for download at his website. Look for msubcd.img. Would that be a better starting point for you?


Posted: Sat Apr 01, 2006 7:55 am
by freeballer
I downloaded that file off his site and then simply copied it to /images/,
I then used the same command as previous and booted into ms dos 7.1 fine... but again it did not "load" my startup.bat file or start ntfspro.exe.
Also I tried using your freedos image to boot into and got similar results

Code: Select all

..... then isolinux memdisk initrd=/images/.... ubcdcmd=ntfs
When you use "ubcdcmd" does that pass arguments to "autoexec.bat" or "config.sys" or append command(s) to a file when it's loaded?
As far as an "external" program(s) or command(s) is there any exceptions or syntax I have to worry about? Any files/folders needed that I could have overwritten or deleted by accident? (I have heavily modified UBCD to a bloated 886mb but everything, including dosapps files (eg. fprot), is working ok.)

Posted: Sat Apr 01, 2006 11:03 pm
by Victor Chew
This is rather strange, since you say other apps like F-Prot works.

Another thing to try might be to copy the files to the directory of an app that is working eg. \dosapps\fprot. Then modify \dosapps\fprot\startup.bat and see if it works. You might be able to figure out something from there.

weird stuff

Posted: Sun Apr 02, 2006 8:21 pm
by freeballer
Thanks for your help victor,
Long story short I found out that I was mostly to blame... I had deleted all docs, license and ubcd folders from the cd to save space and sanity trying to keep track of all folders... But after I deleted \ubcd It stopped ALL bootdisks using the same ubcdcmd method from working.

The code is located @ ubcd.bat in /bin on all of these **ubcd.img bootdisks

Code: Select all

if not "%ubcddrv%"=="" goto _eof
if "%1"==""  goto _end
if "%1"==":" goto _end
set _ubcd=
call drd.bat %1 -$
if errorlevel 100 goto _end
if errorlevel 1 set _ubcd=%1
if not exist %1\ubcd\ubcd.css goto _end
set ubcddrv=%1
goto _eof

Hopefully this will help others who will try this,