Page 1 of 1

XP 64 System Partition Saving Problem

Posted: Tue Apr 18, 2006 2:14 pm
by edwinbradford
I am having such a bad time with this it's unbelievable. For two days now all I've wanted to do is clone (image) my XP64 Pro NTFS partition to my second internal larger NTFS hard drive. Almost none of the commercial imaging software officially supports 64 bit despite some users having success and I've downloaded, burnt to CD and trouble shot :

1 x System Rescue CD: Captive/NTFS doesn't work.
2 x Trinity Rescue Kit: Captive fails, Fuse works but PartImage fails.
3 x Ghost 4 Linux: All three boot CDs had 64 bit kernal panics.
1 x Ultimate Boot CD: can't get Partition Saving to write to NTFS.

Thats seven different programmes and two days of Unix tweaking. OK, here's my current problem with Partition Saving: Everything works fine until I reach where to save the Image file. I mount my NTFS partition which is assigned to 0 (zero). I can see it in the Drives and the Directories windows, in the File entry field I type either 0:\image.par or 0:\volumeName\image.par or \image.par, it makes no difference because every single time I get the message "INVALID OPENED FILE MODE". Admittedly I'm more used to Unix than Dos conventions but I've tried every back slash/ forward slash/ upper case/ lower case/ no suffix/ combination and none of them work. I've mirrored the exact naming conventions in all the walkthroughs but still the same error message above.

Something's wrong. I suspect this is another 64 bit problem. Any ideas? Or just tell me to use something else if you know a better alternative. Cheers -- Edwin.

Posted: Wed Apr 19, 2006 1:31 am
by edwinbradford
OK I found the problem. It's the last FAQ on the Partition Saving site and the English is a little broken. DOS can't write new files to NTFS, therefore you have to create any blank file, a text file would be good, with the name you're going to use to save the image in Partition Saving and overwrite it. Do this in Windows before you boot from the CD. Boot from the CD, launch Partition Saving, then when you come to the save section, select the text file for the destination file and overwrite it.

DOS can overwrite existing files but not create new ones on NTFS. It gets worse, you're going to have to estimate how many files you'll need because for some reason Partition Saving can't save larger than 2GB files so the first file apparently must have the suffix PAR and the second one P01, P02 etc. A simpler option might be to make a new partition just for the destination backups and format it something other than NTFS. You still have the 2GB limit but you don't have to make corresponding text files first.