Lenovo/IBM PC Doctor for TPs in UBCD ?

Try looking for help here if you are having problems with the Ultimate Boot CD.

Moderators: Icecube, StopSpazzing

Posts: 4
Joined: Wed Apr 26, 2006 5:17 pm

Lenovo/IBM PC Doctor for TPs in UBCD ?

#1 Post by asterisk_2a » Wed Apr 26, 2006 5:37 pm


how to get run PC Doctor CD ISO on the UBCD?
http://www-307.ibm.com/pc/support/site. ... MIGR-56222

memdisk doesnt work neither diskemu will work for me. :x

I got running the PC Doc for desktops (diskette). :p

i searched already in the forums but
couldnt get me through it ...

Any Tips for the ISO?


Posts: 90
Joined: Thu Sep 29, 2005 5:44 am

#2 Post by baronvonfoxbat7734 » Thu Apr 27, 2006 7:40 am

Will the executible run froma dos prompt even though it has not loaded off of the CD? If this is the caes, you might be able to extract the contents of the CD to a folder on the root of the UBCD and run from a FreeDOS or a MSDOS floppy image. You cold even customize a bootable floppy to run the CD drivers and then autoexecute the TP executible using the autoexec.bat.

Just an idea of a workaround if you can't get the CD ISO to run from the UBCD. I had to do the same thing with thr Dell Diag utils.

Posts: 4
Joined: Wed Apr 26, 2006 5:17 pm

#3 Post by asterisk_2a » Sun Apr 30, 2006 2:33 pm


no, iam sitting now more than 5 hours on this one thing, and I dosnt get it to work,

Only works for ISOLinux based CDs

isnt helpfull

couldnt help me too

all customization guides are intended to work with Linux (kernel) CD iso images. this pc doctor piece is a dosapp, even if i extract it to the 'dosapps' folder and it executes the autoexec.bat, errors come up ...

baronvonfoxbat7734, maybe you can put your hand on this?

i will look for http://bootcd.narod.ru/index_e.htm if this thing is working.

big thanks

Posts: 4
Joined: Wed Apr 26, 2006 5:17 pm

#4 Post by asterisk_2a » Sun Apr 30, 2006 3:35 pm

even with a floppy img - which is 100mb,
it wont start.


Posts: 90
Joined: Thu Sep 29, 2005 5:44 am

#5 Post by baronvonfoxbat7734 » Mon May 01, 2006 9:56 am

So people can play with this and check it out, may we have a link to the iso you are using for the TP utils?

One thing you can also try is this. Extract the iso to a folder of its own on the root of UBCD. Get the Win98 or WinME boot disk and add it to your UBCD. Of course do this legaly... Once you have added it or another custom MSDOS CD Boot Floppy image, then make your disk and boot to that disk. Once you have booted to the MS CD Boot disk, then run the actual exe file for the TP utils you need. I don't think you can make it autorun... You might be able to create a quick Bat file to do that or edit the config.sys to create a small menu that would allow you to run the appropriate bat file or executible.

It can be done... I don't think using FreeDOS is going to do it though nor is running the autoexec.bat from the iso.

Posts: 4
Joined: Wed Apr 26, 2006 5:17 pm

#6 Post by asterisk_2a » Tue May 02, 2006 12:48 am

PC Doctor for Thinkpads download link:
http://www-307.ibm.com/pc/support/site. ... MIGR-56222

Posts: 90
Joined: Thu Sep 29, 2005 5:44 am

#7 Post by baronvonfoxbat7734 » Wed May 03, 2006 10:57 am

When you open the iso with winrar or another tool that can extract from iso file you see a .bin and a .ima file. Have you tried to put the .ima file onto the CD and used either Diskemu or memdisk? You can try that and see if it works for you. Although I can't remember which one it is but you would most likely want to use the one that does not cache the disk into memory or what have you. I have found that when running the dags and using memdisk it gives errors when scanning the memory due to UBCD sitting in memory.

Try that and see if that helps.

Posts: 1
Joined: Fri Jul 28, 2006 12:32 pm


#8 Post by bigbear » Mon Jul 31, 2006 8:14 am

What solution was found? I am having similar issues. Memdisk appears to work then the system hangs. Diskemu gives me 'boot emulation method not supported.

Victor Chew
Posts: 1366
Joined: Mon Feb 21, 2005 10:59 pm

#9 Post by Victor Chew » Tue Aug 01, 2006 3:41 am

I just downloaded the ISO image myself and tried it out too with various techniques.

No success so far. :cry:

Posts: 1
Joined: Thu Sep 14, 2006 8:32 am

#10 Post by eriqjaffe » Thu Sep 14, 2006 8:47 am

Has anybody been able to make any progress with this? I'd love to have this integrated into my rescue disk...

Posts: 14
Joined: Mon Mar 27, 2006 4:30 pm

#11 Post by alm » Sat Sep 16, 2006 11:32 pm

I believe I extracted this succesfully about seven months ago. I succesfully integrated the Lenevo PC-Doctor (PC-DR) for desktops. I'm not sure if I tested it beyond the 'this machine is not supported' (my home machines aren't IBM), but since I also run the regular PC-DR with the same bootdisk, I don't expect any problems. To cover all recent Thinkpads required about ten different versions, this would take too much space and was too labor-intensive, so I lost interest in the laptop versions.

I'll try to remember what I did. It's quite a long time ago, so don't expect a step-by-step recipe, but it should be enough to get you going. First I extracted the IMA file from the ISO. This IMA file is a hard disk image with one FAT16 partition. I extracted this partition (basically remove the partition table in front of it), but I don't exactly remember how. I probably mounted it as a virtual HD in VMWare and made a disk image by booting Linux in the VM. Copying this to a spare mass storage device (eg. HD) might also work, but the geometry will mismatch and this may cause problems. DOSEMU also understands HD images if I remember correctly. There are probably also Windows programs that can open HD images.
EDIT: just removing the first 16384 bytes does the job. dd if=filename.IMA of=filename.img bs=512 skip=32 does the job on *NIX (or Windows with Cygwin), WinHex can probably do this to, and so can a million other programs.

After the partition was extracted, I just had a plain FAT16 image, which can be mounted in *nix like any other filesystem image (eg. ISO9660). It now contains three directories and a bunch of DOS files. The three directories are three different versions of PC-DR. plnrchk.bat (which is actually in REXX) determines which of these is right for the current machine. I'm not sure how you would handle this in UBCD. It would probably be possible to convert the REXX to a batch file with some external help or just write a C program to do it. You could also add a PC-DOS bootdisk, which has native REXX support. You can also split them up and add three menu entries, but figuring out the exact revision would suck. The version that I used, for Aptiva/NetVista/..., didn't have this problem, since it contains only one version.

If you read autoexec.bat, you can follow the flow. It asks plnrchk.bat for the correct version, and extracts a bunch of self extracting zip files to the ramdisk. I just extracted them all with unzip to ony directory (per version), copied this directory to /dosapps. I copy all files to the ramdisk in startup.bat, see eg. hutil for an example. I use a customized FreeDOS bootdisk which only loads a CD-ROM driver, HIMEM and a ramdrive, because diagnostic software often doesn't like EMM386. This PC-DR might also work with fdubcd, I haven't tried it.