Page 3 of 7

Posted: Tue Jul 05, 2005 1:51 pm
by reblu
Not to worry. If you have WinXP you can go to the Control Panel- Administrative Tools- Computer Management - Disk management and right mouse click on the F: drive (your USB Key) and reformat it.

Posted: Tue Jul 05, 2005 1:52 pm
by Limerick
Limerick wrote: I'm currently trying to format it but I can't even access to it.
But I can access to the Floppy part of it. I can put some files and that's all... :?
Ok I succeed by using the "HP USB Disk Storage Format Tool".

I'm looking forward to get only one Drive and then go to bed.

See you tomorrow.

Thanks to you 3 guys :)

Posted: Tue Jul 05, 2005 1:55 pm
by Limerick
reblu wrote:Not to worry. If you have WinXP you can go to the Control Panel- Administrative Tools- Computer Management - Disk management and right mouse click on the F: drive (your USB Key) and reformat it.
I couldn't : computer hang on when just right-clicking.

But as I said just above, the HP tool managed to do it :)

Posted: Tue Jul 05, 2005 2:25 pm
by reblu
By the way, NwDsk, here are some suggestions for your nice batch program:
- Add freedos.img, grub.iso and offline.iso to your exclude file list. The first one will be overwritten anyway, but this would save the time of copying it from the CD.
- Add Insert to your folder exclude list for now, until we figure out how to make it work.
- Add a warning and wait for keyboard input before executing makebootfat. The warning should say something like "YOUR USB KEY IS ABOUT TO BE REFORMATTED AND ALL ITS CONTENTS WILL BE LOST. Press a key to continue."

Limerick, I would suggest you run a tool like PTEDIT from Powerquest, to see the partition structure of your USB Key. You probably have more than one partition already and we might need to add the -D option to makebootfat so that it operates on the whole disk instead of a partition. You just select the USB Key Drive in the drop down list and then look at the numbers below. If you have more than one row with numbers different than 0, you have more than one partition. Ranish Partititon Manager in the UBCD should show you the same information.

Edit: I actually managed to replicate Limerick's behaviour with my USB key. It happened every time I started with an empty Key. If there was something in it, it did not seem to be a problem. If not, I had to unplug the USB after the error was shown, wait for the Windows sound, and plug the key again. Then rerun the batch file and it worked.

Posted: Wed Jul 06, 2005 2:36 am
by NwDsk
I just uploaded a new version of UBCD2USB:

Reblu, I applied all your remarks. Thanks.

I added an option to switch the general freedos-image to some other DOS-image. In the ubcd2usb-package there is also DRUBCD.IMG which is an OpenDOS version of the general DOS-image. After booting the general DOS-image there is an added button on the last menu that reads "set DOS". By choosing this you may alter the general DOS image for next boot (it just copies it over freedos.img). This means that the end-user may choose which DOS to use. Enter "set DOS" mode by hand by typing "ubcdos.bat".
By adding to the root of your UBCD-USB-key you also add an MsDOS-7 version of the general boot-image (use this only if you possess a license for it!). This adds another DOS giving the option the choose between FreeDOS, OpenDOS and MsDOS for booting the DOS-apps from UBCD.

I also tested makebootfat on the machines at work that I talked of before. They boot now with Reblu's makebootfat-line but then trouble starts. FreeDOS considers the geometry wierd (I tested with 1GB key) and cannot handle it, MsDOS chokes on SmartDrv (probably also geometry), but OpenDOS seems to handle it well (only when booted without EMM386)...
Maybe we can improve the makebootfat setup?


Posted: Wed Jul 06, 2005 3:16 am
by reblu
For FreeDos support, try adding -E 255 to the makebootfat line:
-E, --drive DRIVE
Set the BIOS drive to setup in the FAT boot sector. Generally this value is ignored by boot sectors, with the exception of the FAT12 and FAT16 FreeDOS boot sectors that require the correct value or the value 255 to force auto detection.

Posted: Wed Jul 06, 2005 8:20 am
by NwDsk
Just tested. The -E 255 did not work. We have whole bunches of these machines here. They carry Intel motherboards based on i915G. Only the OpenDOS image (without EMM386) works on these. Would it help to configure makebootfat to format the USB-key as HD instead of ZIP-USB?


Posted: Wed Jul 06, 2005 9:25 am
by Limerick
reblu wrote:If you have more than one row with numbers different than 0, you have more than one partition.
Here is what I get when running PTEDIT32 :


But the fact is the USB key is always seen by XP as 2 drives : one floppy (which does not exist on my laptop and which seems not to be seen by PTEDIT32) and one "Movable Drive" (I don't how it is call in english).

I'll be out this evening and should perform some tries tomorrow. :wink:

Posted: Wed Jul 06, 2005 9:27 am
by reblu
They specifically say
Please note that FreeDos has some problems booting from USB. It works only on very few conditions.

But they do not give further explanations. The example they give actually has the following additional parameters
-E 255 \
-Z \
-m mbrfat.bin -F \
You can try... I'll double check booting my machine from the USB and I'll see if I have problems with Freedos.
[Edit: I just double checked my USB formatted with the original script and Freedos works fine on it. I have an AMI BIOS that allows you to press F8 at boot time and allows you to select the drive to boot from, including USB drives, so it seems to have very good USB support]

Posted: Wed Jul 06, 2005 12:21 pm
by NwDsk
Reblu, it is booting fine on a whole variety of machines, except on those intel-915G-boards. And on those Intels also MsDOS chokes (on smartdrv). I think it has to do with the way the bios on those machines detects bootable USBs. It features a sort of adaptive USB-detection. Depending on the way that an USB-key is formatted with makebootfat it is detected as HD-USB or as FD-USB.
I have been testing before with the 3-way multi-standard booting as explained in the makebootfat doc with the special mbrfat.bin as:
makebootfat -o usb -Y -Z -b ldlinux.bss -m mbrfat.bin -F -c ldlinux.sys image
This booted fine on all my machines except on the same i915G. There the USB-key is detected as FD-USB and neglected in the boot-order. So I guess it is the 'special' handling of USB by the BIOS on those Intel boards ...


BTW, in fact we are not booting FreeDOS with UBCD-USB but SYSLINUX which then chain-boots FreeDOS, so that '-E 255' should not apply here as I interpret it.

Posted: Thu Jul 07, 2005 12:57 pm
by Limerick
Hello guys,

I managed to load ubcd2usb to my USB Key. It's quite long but I have 165 MB of files in there now (I also have 2 Acronis software Images on my UBCD).

But when I try to boot on my desktop (which I previously succeeded to boot on a "normal" USB Key), I have a "Boot Failed" message on the screen.

And on my laptop (which I also succeeded to boot on a "normal" USB Key), I have the following screen :


And each time I hit the Enter Key, I have the "Could not find kernel image : linux" sentence followed by "boot :"

Any idea ?

Posted: Thu Jul 07, 2005 3:34 pm
by reblu
I believe that from Windows you checked that there was some content in the USB Key...

I have some suggestions for your laptop:
1.- Try typing ubusb.c32 at boot prompt
2.- Check that the contents of the ubcdroot subfolder of Erwin's package are actually in the USBKey.

For your destop,
1.- You might want to double-check the configuration of the BIOS and see what options do you have for the USB mass storage drive
2.- Publish here the PTEDIT window of the USB Key that actually worked previously, to see if it was formatted as USB-HDD, USB-ZIP or USB-SuperFloppy. If it is the same one as the one you published before, then it is USB-HDD and you might want to edit ubcd2usb.cmd and remove the -Z from the line
makebootfat -o usb -Z -Y -b ldlinux.bss -m mbr.bin -c ldlinux.sys ubcdroot
Erwin, by the way, with your updated Freedos image i do not seem to have access to the DOS Navigator application. Its folder is empty.

Posted: Fri Jul 08, 2005 8:18 am
by Limerick
Hello reblu,

First of all, I have to say that with the great support of Memup, I managed to delete the Floppy partition of my key.
So now, I only have one partition.

Then I ran again the ubcd2usb h: f: (h: is the UBCD and f: is my key).
It worked but when I tried to boot, I had the same messages as previously for each of my computers.

So here are below the files included in my USB Key, and I don't find the ubcd2usb.cmd :


And finally, I don't have the USB key that worked at boot anymore (I sold it to buy my new Memup), so I can't publish its PTEDIT window.

Posted: Fri Jul 08, 2005 10:16 am
by reblu
The contents of the USB Key look fine to me. You actually have ubusb.c32 in there and syslinux.cfg. If you get that boot prompt, it means that your computer is actually booting from the Key and finding the bootmanager, which is syslinux, but for some reason the syslinux is not finding its configuration file (syslinux.cfg). I guess if you type ubusb.c32 at the boot prompt you also get the "could not find kernel image" message.

I've read that some mainboards can only boot from a HDD-USB formatted Key, others only from a SuperFloppy-USB and others only from a ZIP-USB. The most common scenario is that they can boot from a ZIP-USB formatted drive, and that's what the script ubc2usb does by default.

When I was asking to modify ubc2usb.cmd I was referring actually to the script that you run by typing ubcd2usb h: f:

Go to the folder you were when you typed that, and there you will see that file. It is not a file that gets copied to the USB drive. It is actually a file that can be edited with a text editor. You do not have to remove the whole line mentioned, just remove the "-Z" parameter. That way the Key will be formatted as a HDD-USB. I have noticed that when you change the format of the key, it is better if you unplug it and plug it again before saving files on it. So if the first time you run ubc2usb h: f: it fails, just run it again. Erwin, this might be something that you want to modify in your script, adding a pause and asking for the user to unplug and re-plug the USB key again, just after the makebootfat instruction. Windows sometimes does not realize that the geometry of the drive has changed until you re-plug it.

Another option is that you change your BIOS settings as recommended here:
In most BIOS versions, you will need to go to the 'advanced BIOS settings' section and look for the '1st boot device' entry or the equivalent. Cycle through the possible options in the BIOS. Ideally, you are looking for the USB RMD-FDD option. Failing this, try USB ZIP and USB FLOPPY.
And switch it to USB-ZIP, instead of reformatting the USB Key

Posted: Fri Jul 08, 2005 10:33 am
by Limerick
Thank you so much reblu for your kind and clear explanations.

Probably while you were writing your post, I edited mine because I found the ubcd2usb.cmd file.
Then now, I've deleted the -z command.

You're right, as far as I remember, the previous key was certainly formatted as a HDD-USB.

Now, I'm going to try all your advices and come back here to tell you the results.

Posted: Fri Jul 08, 2005 12:25 pm
by Limerick
No change, even for the laptop or the desktop :?

As you can see on the screen above, the laptop looks for (and find) a USB RMD-FDD.
There's no other possible choice in my laptop's BIOS.

For the desktop, the message "Boot failed" appears for the USB FDD or USB ZIP chosen in the BIOS. No other choice possible.

I wonder why my previous USB Key was able to boot on these two machines... and not this one (with ubcd2usb).

Posted: Fri Jul 08, 2005 2:35 pm
by reblu
In order to clarify a little bit the problems with USB booting, let's look at the 3 basic modes of formatting a USB Key, using my own key as an example :wink:

The main difference is in the partition table. A USB-FDD formatted key does not have one. We just see garbage:

A USB-HDD formatted Key has one partition in the partition table, the first one. The Type 0B tells us that it is FAT32 (06 is FAT16 and 0C is FAT32 LBA). Boot 80 means that the partition is bootable.

A USB-ZIP formatted Key has also one partition in the partition table, but it is the 4th one.

Now, makebootfat allows you to create any of those three basic configurations plus some additional variations. I have modified Erwin's script and actually created three scripts called respectively ubc2usbhdd,ubc2usbfdd and ubc2usbzip, in order to allow formatting the Key in the way that is most compatible with your system. Which is which should be obvious by the name. they can be found here

I have added a pause after the formatting to allow unplugging and plugging the key for Windows to recognize the new geometry.

To use any of them, just unzip them in the same folder where Erwin's original ubcd2usb.cmd is and use them in the same way, eg to configure the key in FDD mode, having h: as the CD and f: as the USB Key, type ubcd2usbfdd h: f:

Just for reference my system seems to recognize faster the drive when it is formatted as FDD and the USB controller in the BIOS is configured as FullSpeed (12Mbps) instead of HiSpeed (480Mbps) .

Posted: Sat Jul 09, 2005 1:36 am
by Limerick
Ok now I think I understand all what you mean... :oops: :wink:

So, at the beginning my key was formatted as a USB-HDD :


But when seeing my boot screen :


I thought I had to format using ubcd2usbfdd

So I had this :


But, I still have the same error message at boot screen... for the laptop.

Because for the desktop, it works !!! :D

The only thing I wish to improve, is my custom menu which allows to launch my 2 Acronis tools : TrueImage and DiskDirector.
Is it difficult ?

So we're on a good way, but there's still a little problem for the laptop.

Thank you again for your patience 8)

Posted: Sat Jul 09, 2005 5:10 am
by reblu
Maybe the best solution would be to use the multiboot option of makebootfat. I have updated my package with an additional ubcd2usbmul file that creates that type of geometry. Its usage is the same as its companions: ubcd2usbmul h: f:.

Note that you do not have to wait until the whole UBCD is copied to the Key. When you get the prompt for unplugging the USB, the usb is already bootable and with the menu in it, so you can actually test it on any computer. Whenever you select an option in the menu you will get an error, though, since the images will not be in the Key yet.

To customize the menu, you have three options:
1.- Just configure syslinux.cfg adding something like

Code: Select all

    KERNEL memdisk
    APPEND initrd=<nameofimage>
replacing <nameofimage> with the image that you actually want to launch. Unfortunately, it has to be in the root folder (it cannot be in a subfolder). Custom1 will be launched whenever you select it in the menu.

2.- If you do not like the name Custom1 that appears and so on, you can use an Hex Editor program like frhed, search for "custom" and replace it with whatever you long as it has the same number of chars...Currently "custom" appears 5 times. One for the menu, one for the submenu header and one for each of the three individual menu subitems. You will still have to configure syslinux.cfg as explained in the previous point.

3.- You can always recompile the menu from the source. I have not been able to do it from Windows, so you will need a Linux box. It is a little bit complex if you do not know Linux at all. I have no problems in making the source available.

I have found that if in my BIOS I configure the USB storage device as USB-FDD or USB-HDD the USB is recognized, but I can only select the option "Boot 1st hard drive" if I boot as "USB-FDD", since when booting as "USB-HDD" the first harddrive seems to be the USB Key itself...

Posted: Sat Jul 09, 2005 7:01 am
by Limerick
I've done a full upload to the key (I had some time to waste ;) ) using ubcd2usbmul.

When I boot the laptop I have this message :


And when I boot the desktop, I have the following message (no picture for this one :oops: )
No operating system
So this solution seems to be a bit worst than the previous one :?

For the point #2, I don't see which file (or files) I have to edit.
By the way, I use UltraEdit, it should be good as frhed, no ?