It is currently Fri Oct 24, 2014 4:01 am

All times are UTC - 8 hours




Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 16 posts ] 

Should I use old CDShell for UBCD 3.4?
Poll ended at Thu Aug 25, 2005 1:16 am
Yes 14%  14%  [ 1 ]
No 86%  86%  [ 6 ]
Total votes : 7
Author Message
 Post subject: Should I use old CDShell for UBCD 3.4?
PostPosted: Thu Aug 18, 2005 1:16 am 
Offline

Joined: Mon Feb 21, 2005 10:59 pm
Posts: 1294
I am debating whether to revert back to CDShell V2.0.11 (the version used in UBCD V3.2) for the next version of UBCD. The reason why I am considering is because there is a problem with CDShell V2.1.6 which prevents it from booting on some machines. The author knows about it and has encountered it himself, but there is no newer version to fix it yet, nor are any definite schedule to do so.

But going back would mean big changes again to the menu files (mainly the syntax for bcdw booting and parameter passing), as well as the loss of certain functions (booting of certain ISO images from diskemu).

I am taking a poll. Do you have enough problems with UBCD V3.3 that you think I should go back to CDShell V2.0.11 for the next version of UBCD? Or do you think I should stick with CDShell V2.1.6? Let me know.


Last edited by Victor Chew on Mon May 14, 2007 6:12 am, edited 1 time in total.

Top
 Profile  
 
 Post subject:
PostPosted: Fri Aug 26, 2005 12:43 am 
Offline
Site Admin

Joined: Mon Feb 21, 2005 8:30 pm
Posts: 12
So looks like the poll overwhelmingly supports continue using the new version of CDShell for the next release of UBCD.

Thanks for all who participated in the poll!


Top
 Profile  
 
 Post subject:
PostPosted: Wed Sep 07, 2005 12:43 pm 
Offline

Joined: Mon Apr 18, 2005 9:07 pm
Posts: 136
Can the older, more compatible version be customized into the CD?


Top
 Profile  
 
 Post subject:
PostPosted: Fri Sep 23, 2005 6:12 am 
Offline

Joined: Mon Feb 21, 2005 10:59 pm
Posts: 1294
Not without some non-trivial change, since there are quite a number of big changes between the old and new versions.


Top
 Profile  
 
 Post subject:
PostPosted: Thu Oct 13, 2005 12:44 am 
Offline

Joined: Wed Feb 23, 2005 12:04 am
Posts: 14
Location: Bucharest, Romania
Administrator wrote:
So looks like the poll overwhelmingly supports continue using the new version of CDShell for the next release of UBCD.

The "overwhelming" support it's only from 6 users.

--sadyc


Top
 Profile  
 
 Post subject:
PostPosted: Thu Oct 13, 2005 8:52 pm 
Offline

Joined: Mon Feb 21, 2005 10:59 pm
Posts: 1294
Ha ha! But in terms of ratio, it's 8 to 1!


Top
 Profile  
 
 Post subject:
PostPosted: Tue Oct 18, 2005 12:38 am 
Offline

Joined: Wed Feb 23, 2005 12:04 am
Posts: 14
Location: Bucharest, Romania
Victor Chew wrote:
Ha ha! But in terms of ratio, it's 8 to 1!

The thing is that UBCD has a lot more users, and statistics done on such a small number of "test subjects" have a huge error margin, which makes them useless.

--sadyc


Top
 Profile  
 
 Post subject: Should I use old CDShell for UBCD 3.4?
PostPosted: Tue Oct 18, 2005 6:59 am 
Offline

Joined: Mon Feb 21, 2005 10:59 pm
Posts: 1294
You are right. Tell you what, I will set up another poll when UBCD V3.4 is
released, and invite users to tell us whether UBCD works with their system. The
poll should be very simple, like:

Does UBCD work with my system:
+ Yes
+ No

Users can also post messages in the same forum topic detailing what went wrong.

Hopefully, if this is sent out with the release alert, more users will pay
attention and participate in the poll.

Another point is not to ask about the CDShell version, which many people may not
understand what it is about, but just take a poll on the success rate of UBCD V3.4.

What do you think?


Top
 Profile  
 
 Post subject:
PostPosted: Wed Oct 19, 2005 4:22 am 
Offline

Joined: Wed Feb 23, 2005 12:04 am
Posts: 14
Location: Bucharest, Romania
It's better yes, and hopefully it will be more useful.
It will have even more coverage if it would be on the main webpage, eventually not requiring the user to have a forum account..
(But this will take time to implement, i guess..)

--sadyc


Top
 Profile  
 
 Post subject: Should I use old CDShell for UBCD 3.4?
PostPosted: Wed Oct 19, 2005 6:55 pm 
Offline

Joined: Mon Feb 21, 2005 10:59 pm
Posts: 1294
Unless anonymous posting is enabled, it is not possible to respond to polls
anonymously too. Is it advisable to enable anonymous posting? I was afraid it
would lead to a lot of spam, like last time when we enabled it for the SF
mailing lists. The spam went away very quickly after I disabled anonymous
posting for the mailing lists.


Top
 Profile  
 
 Post subject:
PostPosted: Tue Oct 25, 2005 4:10 am 
Offline

Joined: Tue Oct 25, 2005 4:00 am
Posts: 5
Location: Poland
@Victor,
I haven't noticed these booting errors when I used UBCD 3.3 - I used it in many machines.
The booting should work on all machines but going back to old version isn't a good idea.
What says CDShell author?

From couple of months I use my modification of CDShell (I've used version from UBCD 3.3 as a base for modifications and mainly I've integrated the new isolinux and memdisk modules (I don't remember if I did something more)).
It works for me without problems.
If you want it I can send it to you, so you can check if there are still the booting errors.


Top
 Profile  
 
 Post subject: Should I use old CDShell for UBCD 3.4?
PostPosted: Wed Oct 26, 2005 7:32 pm 
Offline

Joined: Mon Feb 21, 2005 10:59 pm
Posts: 1294
The CDShell author knows of this issue i.e. booting errors on certain machines.
In fact, he told us he personally encountered it once. But I guess he's
currently too busy to work on it?


Top
 Profile  
 
 Post subject:
PostPosted: Thu Dec 15, 2005 6:01 pm 
Offline

Joined: Mon Apr 18, 2005 9:07 pm
Posts: 136
I'm hoping for maximum compatibility on the next version. What's the upside to the new version of CD Shell?


Top
 Profile  
 
 Post subject:
PostPosted: Thu Dec 15, 2005 11:37 pm 
Offline

Joined: Mon Feb 21, 2005 10:59 pm
Posts: 1294
We will continue to use CDShell V2.1.6 for the next release (UBCD V3.4), instead of reverting back to CDShell V2.0.16.

CDShell V2.1.x supports a number of additional features and changes, including the ability to boot certain ISO images via diskemu (which UBCD uses for some apps).

Check out:

http://www.cdshell.org/download/changes.html

for a full list of changes from V2.0.x to V2.1.x.


Top
 Profile  
 
 Post subject:
PostPosted: Fri Dec 16, 2005 10:01 am 
Offline

Joined: Mon Apr 18, 2005 9:07 pm
Posts: 136
Which ISOs does UBCD currently use so I can use those as examples?


Top
 Profile  
 
 Post subject:
PostPosted: Wed Dec 21, 2005 1:41 pm 
Offline

Joined: Mon Feb 21, 2005 10:59 pm
Posts: 1294
Take a look at grub.iso in filesys.scn, and offline.iso in filesys2.scn.


Top
 Profile  
 
Display posts from previous:  Sort by  
Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 16 posts ] 

All times are UTC - 8 hours


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group