UBCD hangs at boot if you don't press Enter

Report new bugs here, or look at known issues of current and previous releases of UBCD.

Moderators: Icecube, StopSpazzing

Posts: 5
Joined: Wed Dec 10, 2008 2:41 am

UBCD hangs at boot if you don't press Enter

#1 Post by Shank » Wed Dec 10, 2008 4:39 am

The UBCD effectively hangs the machine at boot if you're not there to press Enter within a few seconds of the prompt appearing. This occurs on every system I've ever tried to boot with UBCD 4.1.1.

In order to prevent this, I have to press the Enter key within about three seconds after the prompt appears. Since I'm often working on several machines at the same time, this is rather annoying.

I noticed that UBCD v3.3 went straight to the main menu rather than asking you to press a key. This is the behavior I would prefer.

A brief list of affected systems (yes, I've tried all of these personally):
Dell Optiplex GX240,260,270,280,400
Dell Latitude C600,640,800,810,840
Dell Latitude D400,520,600
Dell Latitude LS,L400
Dell Latitude X200,300
Dell Inspiron 8200
Dell PowerEdge 2400
Dell Precision 360,380
Fujitsu Lifebook S6110
Gateway Solo 9500,9550
IBM Thinkpad A21m
IBM Thinkpad R31
IBM Thinkpad T40,42
some aftermarket ATX/uATX motherboards as well

This is not an exhaustive list - it's only those systems I can think of off the top of my head.

I would love to see this fixed in a future release. In the meantime, though, is it possible to modify the current release (4.1.1) to go straight to the menu?

Please feel free to ask for more information, or more systems tested. I work in a university surplus center, where we see a very large number of PCs.

Posts: 1278
Joined: Fri Jan 11, 2008 2:52 pm

#2 Post by Icecube » Wed Dec 10, 2008 6:25 am

Normally you should have 10 second to press enter.

Replace the contents of isolinux.cfg with the following code (for the CD version):

Code: Select all

MENU INCLUDE /menus/main.cfg
Replace the contents of syslinux.cfg with the following code (for the USB version):

Code: Select all

MENU INCLUDE /menus/main.cfg

Scott Cooper
Posts: 136
Joined: Mon Apr 18, 2005 9:07 pm

#3 Post by Scott Cooper » Sat Feb 07, 2009 9:18 pm

I had no trouble whatsoever with Dell Optiplex GX270s and 280s using 4.1.1, nor when I upgraded the version of ISOlinux that the disc uses to 3.62.