memtest86 and memtest86+ lockup with Gateway 9715

Report new bugs here, or look at known issues of current and previous releases of UBCD.

Moderators: Icecube, StopSpazzing

Posts: 1
Joined: Wed Nov 02, 2005 7:03 am

memtest86 and memtest86+ lockup with Gateway 9715

#1 Post by shawn.sustaita » Wed Nov 02, 2005 7:07 am

The following info is for memtest86+ as well.

Here's our scenario. We ran memtest86 on our new Gateway
9715. This box only connects keyboard and mouse via USB.
When running memtest86, unplug the USB connections and
reconnect. Memtest86 will lock up. I suspect it's the
USB driver in whatever kernel memtest86 uses.

Now, I tried unplugging and reconnecting the USB cables
when a RHEL AS 3 OS was running and there were no problems.
I tried this numerous times.

Posts: 4
Joined: Sun Jun 19, 2005 2:41 am

memtest86 and memtest86+ lockup with Gateway 9715

#2 Post by pointy » Thu Nov 03, 2005 5:41 am

memtest86+ doesn't have a USB driver -- it relies on the BIOS for all USB support, so
I would guess that your BIOS is mis-behaving on this particular USB event. I would
suggest that the BIOS is simply trampling over RAM that's in use by memtest86+ for
something (there are a number of workarounds in test.c for similar problems).

you should probably report this to the memtest86+ developers to help them make a
workaround. make sure you try the latest version (1.65) first!

Scott Cooper
Posts: 136
Joined: Mon Apr 18, 2005 9:07 pm

#3 Post by Scott Cooper » Sun Nov 06, 2005 6:55 pm

An intresting bug, but are you saying this only locks up when USB devices are unplugged and replugged?

Posts: 19
Joined: Mon Apr 11, 2005 1:41 pm

Disable USB Legacy support

#4 Post by PsiMoon314 » Wed Dec 21, 2005 2:36 am


Check that you have USB legacy support disabled in your BIOS setup.

Some BIOSes have a bug in them which causes memtest to write over the memory area used by the USB legacy support resulting in freezes or reboots.

Other memory tests may show the same issues.