Page 1 of 1

I'd like to use v5 but ...

Posted: Tue Nov 04, 2008 11:38 am
by Marsha
I'm a long-time v4 (and earlier) user. Add my own images of new and/or missing things and am very happy.

Glad there is this great update effort. Not sure why the large effort over Parted Magic, but I'll learn I guess.

My big problem with v4 has been the fact that it is only useful to me from CD, not USB flash because so many images (dos) won't boot but just hang. A well-known memdisk problem I believe. Maybe or maybe not that will be fixed in v5 - right now it seems to be ignored.

Anyway on to my immediate problem.

I just downloaded v5 and it works great from a CD. When I attempt to put it onto a flash drive (extract contents to a folder, run ubcd2usb out of tools) I get the normal message Formatting usb key, then a message "Invalid drive specification."

Then it goes on to say making USB Key bootable, and puts the files on it.

Of course, to my dismay, it isn't bootable. Not a problem I ever saw with v4 at all. It just hangs - no boot.

If I rerun the ubcd2usb script, it says the same thing, but clearly isn't formatting the key since then it asks about overwriting files from the previous attampt. They would be gone if a format had really occurred, right.

Anyoone got any help at this most basic step?



Posted: Tue Nov 04, 2008 12:01 pm
by Icecube
You have to specify the right drive you want to format and to which you want to install ubcd.

Run /ubcd/tools/ubcd2usb/run.cmd and follow the instructions.

You also can format the drive manually:
- Open cmd.exe (Start ==> Run ...)
- format x: /v:UBCD50B5 /x /q (Change x: to the correct drive letter for your usb stick)

Posted: Tue Nov 04, 2008 1:42 pm
by Marsha
Well, no joy yet.

First, thanks for the very quick response. Yes, I was making an odd error in the creation of the key. I was using "G:\" for the flash, which didn't cause a problem with 4.11 but of course, once I used the proper "G:" it formatted just fine and copied the files, etc.

However, it still doesn't boot - just a simple "move the cursor down one line" and hang.

Next suggestion, please.


Posted: Tue Nov 04, 2008 2:01 pm
by Icecube
Can you tell exactly what you see on your screen, when you boot the stick?

Have you tried to set the bios to USB-HDD, USB-zip, USB-FDD?

Some bioses have a broken bios support (some Gigabyte boards for example).

Posted: Tue Nov 04, 2008 2:27 pm
by Marsha

Nothing at all on the screen - as I said just a blinking cursor.

The bios is set correctly (on 3 different machines.) two different keys, all work just fine with 4.11 on them, not with this new 5.

My motherboards are all ASUS, from 3 months to 2 years old and have no problem with bios support for booting. All the bios are set to Forced-FDD boot support (that's the Zip way.)

I really do appreciate the prompt responses, but can you suggest something else. Since my UBCD 4.11 keys work, my Image for Dos key works, even my new key with UBCD4Windows works (very slowly!), I don't think the problem is the computers.


Posted: Tue Nov 04, 2008 2:31 pm
by Icecube
Try the USB-HDD setting in the bios (it isn't so strick about the formatting of the usb thumb drive). Recent bioses should support it. I always choose it on my PC's.

You also can try an older syslinux version (or wait a week or so untill a newer version comes out).

Posted: Tue Nov 04, 2008 2:43 pm
by Marsha
Your experience is different than mine. I've never had HDD work with a flash drive.

However, at your suggestion, I just tried it again. Same results I always see - pause at boot and then boot the hard disk into XP. So, nothing that works.

I really have no clue where to find an older syslinus boot program.

Would you suggest I just move the syslinux folder from my 4.11 to the 5 folder?

Got any idea why this is so difficult and maybe a change to something that can be debugged better might be a good move?

I appreciate the help


Posted: Tue Nov 04, 2008 3:02 pm
by Icecube
Try to make your stick bootable again (manually). Be sure that you have administrator rights:
- Delete /syslinux/ldlinux.sys on your usb stick
- Open /ubcd/tools/ubcd2usb/run.cmd
- Type the following on the command prompt (change x: with the drive letter of your usb stick).

Code: Select all

syslinux -ma -d syslinux x:
- When you look again in the /syslinx/ directory, you should see the ldlinux.sys file again.

Try all bootoptions in your BIOS and look at which option the bios tries to read from your usb stick (led lights up). This will probalby the case with the Forced-FDD boot option.

If the syslinux bootsector is correctly written, then you should see a message with SYSLINUX in it. If this is not the case, the bootsector isn't written.

Posted: Tue Nov 04, 2008 3:07 pm
by Marsha
Be there in a couple of minutes. Thanks for hanging in there with me

Posted: Tue Nov 04, 2008 3:29 pm
by Marsha
Followed directions carefully.

Yes, ldlinux.sys was properly recreated.

Boot (with forced-fdd) lights-up the flash just fine.

No message, just a blinking cursor.

So, that says the boot sector isn't being written, I guess.

What can I do for the next step?

Posted: Tue Nov 04, 2008 3:57 pm
by Icecube
Download the last syslinux package from:

Download HDHACKER from:

Extract the sylinux package and search for the mbr file (mbr.bin) in the core directory.

Update the mbr of your usb stick with the syslinux mbr file (Use HDHacker).

Posted: Tue Nov 04, 2008 4:07 pm
by Marsha
Whew, this isn't exactly general user stuff, is it.

BTW, I've tried the previous stuff with 2 different flash drives from different manufacturers - no difference (Corsair 1GB and SanDisk 256Mb)

I'll give it a go and report. Thanks.

Posted: Tue Nov 04, 2008 4:35 pm
by Marsha
Ok did all that. It really wasn't so hard.

But no joy. Actually no change at all - just the blinking cursor.

Using HDHacker, I loaded the mbr.bin file and wrote it to physical drive 1 (the flash drive). Seemed to work just fine. I didn't know what I should check so I just went with it.

Anything I can check to see what's going on?

Posted: Tue Nov 04, 2008 5:07 pm
by Icecube
You can read the mbr back from the disk with the read sector from disk and compare it with the mbr.bin file (hexeditor).

The keys that you are using, are it the same keys that have contained UBCD411? The formatting of the usb stick has changed with UBCD500 (can't find the post of Victor right now, but only USB-HDD and one other USB method are supported (don't remember which)).

Probably your usb stick has a wrong geometry for your BIOS. See /doc/usbkey.txt of the sylinux package for more information. You will need linux do make your key. You can download Puppy linux (less than 100MB) and run it in a virtual machine. Probably it is possible to do it in windows also, but I don't know how.
Maybe you can ask it at the

Or ask it at the syslinux mailing list.

Posted: Wed Nov 05, 2008 4:29 am
by Marsha
Thank you, Icecube, for all your help. I really appreciate it.

Yes, I checked the mbr (sector 0) and it compares fine (first 404 bytes, all that is in the mbr.bin file.

USB keys (yes, I do use then with lots of devices, both booting and not) do not have a geometry - geometry is what needs to be in the mbr sectors to match with what a bios expects. A flash drive is just a linear set of sectors (blocks). The formatting program and the mbr data that gets written determine the geometry.

So, unfortunately, it's the syslinux, etc programs that are supposed to prepare my flash drives that aren't working properly for my ASUS/AMI bios, I guess.

No, I don't think I'll keep asking around at other sites, etc. I simply wanted to use the good tools that Victor (and now with your help) is putting together. They seem to work just fine (at least to booting) on a CD, just not on a USB flash drive. Unfortunately, I think that's the future of booting tool sets, at least for me since I'm seeing more and more laptops without even a CD drive, and the convenience of the flash is outstanding. Too bad the bios vendors made this difficult and the low level tools folks haven't figured it out yet.

If the syslinux stuff isn't going to make all this automatic for the majority of users, maybe something else will. I hope you and Victor fine it. I will keep checking back to see what I can use or if I can help.

Thanks again for your patience and help.

Posted: Wed Nov 05, 2008 5:52 am
by Icecube
You can try the formatting programs vformat or mformat.

You can format your drive correctly with makebootfat (used in UBCD411). According to Victor Chew, it doesn't always its job right and therefore it is removed in the UBCD500 version.

If you can give the exact size of your USB sticks, I can make a correct disk layout for you.