Ultimate Boot CD
http://www.ultimatebootcd.com/forums/

UBCD 5.0 - Vista RE, Multiple WIMs, OS Install/Diagnostics
http://www.ultimatebootcd.com/forums/viewtopic.php?f=7&t=1931
Page 2 of 2

Author:  Icecube [ Fri Jul 24, 2009 2:52 am ]
Post subject: 

delicatepc wrote:
If I understand you correctly this will be fixed in syslinux 3.83? No need for a special "patched" version?

It is fixed in syslinux-3.83-pre1:
http://www.kernel.org/pub/linux/utils/boot/syslinux/Testing/

Author:  cool2bdave [ Tue Aug 25, 2009 9:37 am ]
Post subject:  Failed to load the boot file

Hi I must be doing something wrong. Could some king person check what I have done to ensure that I have not done anything silly?
Thanks
David

My Proceedure:
I have created UBCD50B12 using:
c:\ubcd50b12\ubcd\tools\win32\ubcd2usb\ubcd2usb.bat

I then updated my main.cfg on my Flash Drive (I tried with and without the "boot" keyword)
F:\ubcd\menus\syslinux\main.cfg
Code:
MENU INCLUDE /ubcd/menus/syslinux/defaults.cfg
DEFAULT /boot/syslinux/menu.c32
PROMPT 0

F1 /ubcd/menus/syslinux/pmagic1.hlp
F2 /ubcd/menus/syslinux/pmagic2.hlp

[color=darkred]LABEL -
MENU LABEL Test
COM32 /boot/syslinux/chain.c32
APPEND ntldr=/BOOTMGR[/color]

LABEL -
MENU LABEL System
KERNEL /boot/syslinux/menu.c32
APPEND /ubcd/menus/syslinux/system.cfg
etc...


I then copied the BCD from my Vista SP2 DVD d:\boot\BCD to my Flash Drive F:\boot\BCD

I ran the batch file:
F:\boot\bcdupdate.bat

Code:
Rem BCD (boot configuration data) editor for multiple vista pe

REM THIS IS THE ORIGINAL BCD FILE EXTRACTED FROM ANY VISTA WINPE / VISTA DVD (I USED VISTA INSTALLATION)
set BCD-File="f:\boot\bcd"

REM SET THE NAME FOR THE VISTA PE HERE
set pename="Network Boot Windows PE"

REM SET THE NAME FOR THE WIM.FILE HERE WITH PATH
set filena=[boot]\sources\boot32.wim

for /f "eol=r tokens=1-2" %%a in ('bcdedit /store %BCD-File% /ENUM all') do set rdo=%%b


for /f "tokens=1-7" %%a in ('Bcdedit /store %BCD-File% /copy {default} /d %pename%') do set guid1=%%g
bcdedit /store %BCD-File% /set %guid1:~0,38% DEVICE ramdisk=%filena%,%rdo%
bcdedit /store %BCD-File% /set %guid1:~0,38% OSDEVICE ramdisk=%filena%,%rdo%

bcdedit /store %BCD-File% /ENUM
pause


I then coppied the chain.c32 from
http://www.boot-land.net/forums/index.p ... st&id=8729
to F:\boot\syslinux\chain.c32

Finally I copy my wim image to F:\[BOOT]\sources\boot32.wim

wim info:
Code:
F:\[BOOT]\sources>imagex /info boot32.wim

ImageX Tool for Windows
Copyright (C) Microsoft Corp. All rights reserved.



WIM Information:
----------------
GUID:        {897264f1-1257-4f8a-bb8f-c8ba6eecef2f}
Image Count: 1
Compression: LZX
Part Number: 1/1
Boot Index:  1
Attributes:  0x8
             Relative path junction


Available Image Choices:
------------------------
<WIM>
  <TOTALBYTES>120230082</TOTALBYTES>
  <IMAGE INDEX="1">
    <NAME>Network Boot Windows PE</NAME>
    <WINDOWS>
      <ARCH>0</ARCH>
      <PRODUCTNAME>Microsoft« Windows« Operating System</PRODUCTNAME>
      <PRODUCTTYPE>WinNT</PRODUCTTYPE>
      <PRODUCTSUITE></PRODUCTSUITE>
      <LANGUAGES>
        <LANGUAGE>en-US</LANGUAGE>
        <DEFAULT>en-US</DEFAULT>
      </LANGUAGES>
      <VERSION>
        <MAJOR>6</MAJOR>
        <MINOR>0</MINOR>
        <BUILD>6001</BUILD>
        <SPBUILD>18000</SPBUILD>
      </VERSION>
      <SYSTEMROOT>WINDOWS</SYSTEMROOT>
    </WINDOWS>
    <DIRCOUNT>537</DIRCOUNT>
    <FILECOUNT>3358</FILECOUNT>
    <TOTALBYTES>354176786</TOTALBYTES>
    <CREATIONTIME>
      <HIGHPART>0x01CA1F30</HIGHPART>
      <LOWPART>0x8B118F9F</LOWPART>
    </CREATIONTIME>
    <LASTMODIFICATIONTIME>
      <HIGHPART>0x01CA1F30</HIGHPART>
      <LOWPART>0x8B5EE4A2</LOWPART>
    </LASTMODIFICATIONTIME>
  </IMAGE>
</WIM>


I then boot with my USB drive, choose Test from the menu and get:
Code:
Loading the boot file...
Failed to load the boot file
boot:


Any ideas?

Author:  Icecube [ Tue Aug 25, 2009 11:21 am ]
Post subject: 

You don't have copied /BOOTMGR to the root of your drive (doesn't need to be there if you edit the path for BOOTMGR on the APPEND line properly.
Code:
COM32 /boot/syslinux/chain.c32
APPEND ntldr=/some/folder/BOOTMGR

The wim file need to be in BOOT\sources not in [BOOT]\sources.

Author:  delicatepc [ Tue Aug 25, 2009 11:21 am ]
Post subject: 

BOOT.WIM should be:

F:\SOURCES\BOOT.WIM (not F:\(BOOT)\SOURCES).

The (boot) the script is referring to you need to disregard.

but the problem you are seeing likely because...
You didn't update your syslinux. .
http://www.kernel.org/pub/linux/utils/boot/syslinux/Testing/syslinux-3.83-pre9.zip
Dont update syslinux.cfg from syslinux package.

Update isolinux.bin - located in syslinux/core
Update chain.c32 - located in syslinux/com32/modules
Update ldlinux.sys - located in syslinux/core
Update memdisk - located in syslinux/memdisk
Update menu.c32 - located in syslinux/com32/menu
Update reboot.c32 - located in syslinux/com32/modules
Update vesamenu.c32 - located in syslinux/com32/menu

Also see this thread (someone who also had questions):
http://www.ultimatebootcd.com/forums/viewtopic.php?t=1981

Author:  delicatepc [ Tue Aug 25, 2009 11:26 am ]
Post subject: 

Icecube wrote:
You don't have copied /BOOTMGR to the root of your drive......
Yes Icecube is also correct - It looks like you didnt copy over the required files from Vista/Win7 cds.

Need at least the follow (F: is my usb drive):
Code:
F:\BOOTMGR

F:\BOOT
F:\BOOT\BCD
F:\BOOT\BOOT.SDI
F:\BOOT\bootsect.exe
F:\BOOT\ETFSBOOT.COM
F:\BOOT\memtest.exe

F:\BOOT\isolinux
F:\BOOT\isolinux\isolinux.bin
F:\BOOT\isolinux\isolinux.cfg

F:\BOOT\syslinux
F:\BOOT\syslinux\chain.c32
F:\BOOT\syslinux\ldlinux.sys
F:\BOOT\syslinux\memdisk
F:\BOOT\syslinux\menu.c32
F:\BOOT\syslinux\reboot.c32
F:\BOOT\syslinux\syslinux.cfg
F:\BOOT\syslinux\vesamenu.c32

F:\BOOT\en-us
F:\BOOT\en-us\bootsect.exe.mui

F:\BOOT\FONTS
F:\BOOT\FONTS\CHS_BOOT.TTF
F:\BOOT\FONTS\CHT_BOOT.TTF
F:\BOOT\FONTS\JPN_BOOT.TTF
F:\BOOT\FONTS\KOR_BOOT.TTF
F:\BOOT\FONTS\WGL4_BOOT.TTF

F:\ubcd (cropped this section)

F:\EFI
F:\EFI\MICROSOFT
F:\EFI\MICROSOFT\BOOT
F:\EFI\MICROSOFT\BOOT\BCD
F:\EFI\MICROSOFT\BOOT\FONTS
F:\EFI\MICROSOFT\BOOT\FONTS\CHS_BOOT.TTF
F:\EFI\MICROSOFT\BOOT\FONTS\CHT_BOOT.TTF
F:\EFI\MICROSOFT\BOOT\FONTS\JPN_BOOT.TTF
F:\EFI\MICROSOFT\BOOT\FONTS\KOR_BOOT.TTF
F:\EFI\MICROSOFT\BOOT\FONTS\WGL4_BOOT.TTF

(notice here that you only need 3 files from the Win7/vista installers: boot.wim, install.wim, and setup.exe)
F:\SOURCES
F:\SOURCES\BOOT.WIM
F:\SOURCES\install.wim
F:\SOURCES\setup.exe

Author:  cool2bdave [ Tue Aug 25, 2009 12:14 pm ]
Post subject: 

Icecube and delicatepc thanks for your replies. I will try this out at work first thing tomorrow.

I think I was confused as ubcd50b12\ubcd\tools\win32\ubcd2usb\ubcd2usb.bat coppied the [boot] directory to the Flash Stick. It contains Bootable_NoEmulation.img, should this be in the root?

Thanks again

Author:  Icecube [ Tue Aug 25, 2009 12:46 pm ]
Post subject: 

Delete the [BOOT] folder altogether. It is not needed at all. Bootable_NoEmulation.img is the bootable part of the iso (first 2kb of isolinux.bin). When you recreate the iso, this file is recreated (you can only see it when you extract the iso with 7zip).

Author:  cool2bdave [ Wed Aug 26, 2009 6:21 am ]
Post subject: 

Thanks for your help so far.

I have had some success. I can get the wim file to boot from the GRUB4DOS menu.

However

The syslinux menu shows:
Loading the boot file...
Booting...
Chainboot failed!

Any Ideas?


My Setup is as follows:

Code:
F:.
|   autorun.inf
|   license.txt
|   BOOTMGR
|   
+---antivir
|   |   (Cropped)
|           
+---BOOT
|   |   ETFSBOOT.COM
|   |   memtest.exe
|   |   BOOT.SDI
|   |   bootsect.exe
|   |   BCDUpdate.bat
|   |   BCD
|   |   
|   +---isolinux
|   |       isolinux.cfg
|   |        isolinux.bin
|   |       
|   +---syslinux
|   |       syslinux.cfg
|   |       chain.c32
|   |       memdisk
|   |       menu.c32
|   |       reboot.c32
|   |       vesamenu.c32
|   |       
|   \---FONTS
|           CHS_BOOT.TTF
|           CHT_BOOT.TTF
|           JPN_BOOT.TTF
|           KOR_BOOT.TTF
|           WGL4_BOOT.TTF
|           
+---pmagic
|   |   (Cropped)
|           
+---ubcd
|   |   ubcd.ico
|   |   
|   +---boot
|   |   (Cropped)
|   |           
|   +---custom
|   |       (Cropped)
|   |       
|   +---dosapps
|   |       (Cropped)
|   +---images
|   |       (Cropped)
|   |       
|   +---menus
|   |   +---grub4dos
|   |   |   |   bios.lst
|   |   |   |   cpu.lst
|   |   |   |   hdd.lst
|   |   |   |   main.lst
|   |   |   |   memory.lst
|   |   |   |   others.lst
|   |   |   |   periph.lst
|   |   |   |   system.lst
|   |   |   |   
|   |   |   \---hdd
|   |   |           (Cropped)
|   |   |           
|   |   \---syslinux
|   |       |   bios.cfg
|   |       |   cpu.cfg
|   |       |   defaults.cfg
|   |       |   hdd.cfg
|   |       |   main.cfg
|   |       |   memory.cfg
|   |       |   others.cfg
|   |       |   periph.cfg
|   |       |   pmagic1.hlp
|   |       |   pmagic2.hlp
|   |       |   system.cfg
|   |       |   
|   |       \---hdd
|   |              (Cropped)
|   |               
|   \---tools
|       +---(Cropped)
|                   
\---sources
        boot32.wim


I Updated:
isolinux.bin
chain.c32
ldlinux.sys
memdisk
menu.c32
reboot.c32
vesamenu.c32
I used: http://www.kernel.org/pub/linux/utils/b ... 3-pre9.zip


I coppied the windows boot files from Windows OPK\Tools\PETools\x86\boot

I updated my BCD:
Code:
Windows Boot Manager
--------------------
identifier              {bootmgr}
description             Windows Boot Manager
locale                  en-US
inherit                 {globalsettings}
default                 {default}
displayorder            {default}
toolsdisplayorder       {memdiag}
timeout                 30

Windows Boot Loader
-------------------
identifier              {default}
device                  ramdisk=[boot]\sources\boot32.wim,{7619dcc8-fafe-11d9-b4
11-000476eba25f}
path                    \windows\system32\boot\winload.exe
description             Network Boot Windows PE
locale                  en-US
inherit                 {bootloadersettings}
osdevice                ramdisk=[boot]\sources\boot32.wim,{7619dcc8-fafe-11d9-b4
11-000476eba25f}
systemroot              \windows
detecthal               Yes
winpe                   Yes
ems                     Yes


The F:\ubcd\menus\syslinux\main.cfg Label is updated to:
Code:
MENU LABEL Test
COM32 /boot/syslinux/chain.c32
APPEND boot ntldr=/BOOTMGR


The F:\ubcd\menus\grub4dos\main.lst has the following added:
Code:
title Test
chainloader /BOOTMGR
boot

Author:  delicatepc [ Wed Aug 26, 2009 6:43 am ]
Post subject: 

Code:
MENU LABEL Test
COM32 /boot/syslinux/chain.c32
APPEND boot ntldr=/BOOTMGR
This is what I currently have (and it works).

Did you update the syslinux.exe file and run the syslinux install again (ubcd2usb.cmd)? I believe the ldlinux.sys is updated.

I had same issue when I was trying to get this to work for me originally. http://www.msfn.org/board/lofiversion/index.php/t135148.html

Its theoritically possible that the latest chain.c32 is having an issue. I am specifically using the chain.c32 module from syslinux.3.83pre6. http://www.kernel.org/pub/linux/utils/boot/syslinux/Testing/syslinux-3.83-pre6.zip

Thanks,
dpc

Author:  cool2bdave [ Wed Aug 26, 2009 7:41 am ]
Post subject: 

Thank you, updating the syslinux.exe was the final key.

I didnt bother running the whole batch script I just ran
ubcd50b12\ubcd\tools\win32\ubcd2usb\syslinux.exe -ma -d boot\syslinux f:
This did its magic and it all works.

Now for some further hacking

Thanks again delicatepc and Icecube

Author:  krzyk_91 [ Sat Mar 27, 2010 6:21 am ]
Post subject: 

Hi, I have got a question about the tutorial. I would like to add Active Boot Disk and ESET SysRescue to my multiboot DVD (which I'm creating using http://www.911cd.net...ame+Joliet+name ). I runed the script on Windows XP, and I got an error, that I haven't bcdedit command. I know, that the command is in Windows Vista and 7. My question is, if I can do my DVD on Windows XP or should I use Windows 7 or maybe there is an other method to add Bootmgr files to UBCD

Author:  dyoll1013 [ Fri Aug 13, 2010 6:10 am ]
Post subject:  Re: UBCD 5.0 - Vista RE, Multiple WIMs, OS Install/Diagnostics

For anyone else who, like me, found this thead and couldn't figure out why it wasn't working:

If you upgraded syslinux to version 4 or higher, you must use this code in your menu to load bootmgr:
Code:
LABEL -
    MENU LABEL Whatever you Like
    COM32 /boot/syslinux/chain.c32
    APPEND fs ntldr=/BOOTMGR


Otherwise when you chain bootmgr you'll get an error like:

Quote:
File: \Boot\BCD
Status: 0xc0000225
Info: An error occurred while attempting to read the boot configuration data.


Credit for this fix goes to Icecube and delicatepc on this thread: http://www.boot-land.net/forums/index.p ... opic=11943

Page 2 of 2 All times are UTC - 8 hours
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/