Ultimate Boot CD
http://www.ultimatebootcd.com/forums/

Some Custom images don't boot
http://www.ultimatebootcd.com/forums/viewtopic.php?f=7&t=2140
Page 2 of 2

Author:  uncle joe [ Fri Dec 25, 2009 11:50 am ]
Post subject:  Memdisk 3.84

Hi Icecube,

Sorry i have not enough time to work on this problem. But today i've tried with the last release of syslinux (http://www.kernel.org/pub/linux/utils/b ... x-3.84.zip)

i've add the file memdisk in the folder and i've changed the name : /boot/syslinux/memdisk-new.

Then i try in my virtual machine (updated) Sun Virtualbox 3.1.2 r56127, and it works ....

Between your message and today fortunately the new release of syslinux is out (3.84) and it seems to solve my problems with custom images.

By the way i'm using these old software to create new partitions not to resize them. i'm using directly software included (by Microsoft) in Windows Vista / Windows 7 for shrinking space.

Thanks again for your help. :D

Joe

PS : with the new release of syslinux (3.84) i don't have to add commands to the APPEND line, it seems to work out of the box.

Author:  uncle joe [ Sat Dec 26, 2009 11:00 am ]
Post subject:  Problem almost solved ...

Hi everyone,

I've made a few tests and alls of my custom images works under my virtual pc.

But ... i've made a quick test with Powerquest Partition Magic but it fails on a real computer. I'm going to make a few tests (with different parameters) to try.

I will appreciate to edit on the fly (like in grub) when you press the E key.

Joe

Author:  Icecube [ Sat Dec 26, 2009 11:08 am ]
Post subject: 

To edit on the fly with the Syslinux (or Isolinux) bootloader, press <TAB>.

Author:  uncle joe [ Sat Dec 26, 2009 5:09 pm ]
Post subject:  Thanks for the tip ...

Hi again Icecube,

Very useful the key tab for editing. Happy to know this trick (it allow me to save a few cd-r from burning).

About the tool Powerquest Partition Magic (version 8.0) it work fine on both side now : On a virtual pc (VirtualBox) and on real computers. (The new release of Memdisk seems to help also)

I just have to add on the append line the command : raw. It seems to only concern some DR-DOS floppies like Partition Magic and Drive Image. A tool like Ontrack Disk Manager release 10.46 uses DR-DOS and seems to don't need a fix, Ghost is using PC-DOS and don't need a fix with the new release of Syslinux / Memdisk.

Thanks again for your help.

Joe

Author:  crazydrve [ Wed Jan 06, 2010 12:17 am ]
Post subject:  custom images wont boot

Hi I am getting the same issue where my custom images wont boot...

i was wondering how to update syslinux?

thanks for any help

Author:  Icecube [ Wed Jan 06, 2010 10:08 am ]
Post subject: 

Download Syslinux from:
http://www.kernel.org/pub/linux/utils/boot/syslinux/

Extract it.
Copy /memdisk/memdisk of the extracted syslinux archive to the /boot/syslinux folder of your UBCD install (your USB stick) or to the folder where you want to rebuild the ubcd iso (if you need the CD version ==> run /ubcd/tools/win32/ubcd2iso/ubcd2iso.cmd to build the iso).

Other syslinux files don't need to be updated, but just in case you want it:
Copy to /boot/syslinux (UBCD), the following files of the Syslinux archive:
Code:
/com32/menu/menu.c32
/com32/menu/vesamenu.c32
/com32/modules/chain.c32
/com32/modules/reboot.c32

Copy /core/isolinux.bin to /boot/isolinux (UBCD) (for ISO).
Copy /win32/syslinux.exe to /ubcd/tools/win32/ubcd2cmd/. (for USB: run the ubcd2usb.cmd script or run:
Code:
syslinux.exe -d /boot/syslinux X:

directly (replace X: with the correct drive letter for your USB stick).)

Author:  crazydrve [ Wed Jan 06, 2010 1:21 pm ]
Post subject:  custom images wont boot

thanks for the info that will save time in future...
I had already figured it out just by playing with it and reading other areas of the forum...

I just love ubcd 5 and how u can add ISO files...

I know its piracy from what i have read but as long as u have licenses its legal... we use it at college helpdesk...

I added the Hiren 10 boot cd as iso and it worked

I know have ubcd and hiren on flash drive...


thank you very much
crazydrve

Author:  delicatepc [ Thu Feb 04, 2010 12:44 am ]
Post subject:  Re: custom images wont boot

Unclejoe thanks for following up and helping locate that syslinux issue. I know it can be time consuming to test and document these things. Much appreciated.

crazydrve wrote:
I know its piracy from what i have read
To my knowledge UBCD doesnt use anything that violates any licenses and/or pirates. I did some research for some of the apps I use and they all check out. As for Hiren that may be a different story - I have it filed under testing/experimental/grey area app. I have tried it using the USB booting as ISO and it works with some quirks (ie maps the drive in the wrong place etc); I found the syslinux/extracted version was a little bit more stable/less bugs.

~dpc

Page 2 of 2 All times are UTC - 8 hours
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/