It is currently Sun Jul 27, 2014 10:16 pm

All times are UTC - 8 hours




Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: UBCD & KVM switch help
PostPosted: Mon Aug 22, 2011 8:58 am 
Offline

Joined: Mon Aug 22, 2011 8:30 am
Posts: 2
I will start by apologizing if this issue has been posted on before but I was unable to locate any information in the forum. I have been using UBCD for almost 2 years at my current employer to wipe/test hard drives and load custom images for machines we refurbish. I like UBCD because I can have hard drives from 4 different manufacturers at any one time and it saves me the hassle of having to track down a bunch of different diagnostic disks when i can just boot an all in one tool from a flash drive. I also use it for testing memory and burning systems in after I finish cloning the image.

We recently moved to a new location and I got free reign to setup a new test bench and purchased a new pc with plenty of extra ports for all my testing and cloning, our thoughts were that we would run this system through a kvm switch so that our other diagnostic pc which is always booted into xp could share same monitor, mouse, and keyboard.

The problem is that regardless of whether I boot UBCD from a cd or usb drive in this new system I can NOT get the menu to respond to either a ps2 or usb keyboard while it is plugged into the KVM. If I reboot the system and plug either keyboard directly into the motherboard I can use the UBCD just fine. (Legacy USB is enabled in the BIOS)

I have tried 5 different keyboards to no success. The switch works fine on the other pc with xp booted and all ports on the switch have been tested so it doesn't seem to be a bad switch. A separate power supply was also purchased with the KVM switch both of which came from QVS to make sure that there was ample power for the bus.

My question now becomes:

1. Is this an incompatability with this intel motherboard ( model: DG41TY ), and this brand of KVM switch? (If anyone is doing a similar setup and has this working could you list your brand of KVM switch and motherboard manufacturer)

2. Is there a driver or something that is not getting loaded by booting the UBCD that is needed for the KVM so that the keyboard is recognized?

Thanks in advance for any ideas!


Top
 Profile  
 
 Post subject: Re: UBCD & KVM switch help
PostPosted: Mon Aug 22, 2011 6:29 pm 
Offline

Joined: Mon Apr 30, 2007 11:06 am
Posts: 294
Location: FL
Are you setting the KVM switch to the diagnostic pc while booting the new system then switching? If so, try setting the KVM to the new pc prior to booting to UBCD so the keyboard is connected to the new pc.

I do recall reading about a Linux version/distro that had a similar issue.

Edit: Here is a similar post to the one I mentioned --> http://www.linuxforums.org/forum/ubuntu-linux/175410-trouble-kvm-switch.html


Top
 Profile  
 
 Post subject: Re: UBCD & KVM switch help
PostPosted: Mon Aug 22, 2011 7:07 pm 
Offline

Joined: Sat May 08, 2010 5:26 am
Posts: 750
In addition to what The Piney recommends about connecting FIRST the KVM and only then booting, check your BIOS for any PS/2 setting. Older mainboards used to have such settings.

Between PS/2 and USB keyboards (and mouse), try using ps/2, simply because old programs will be more compatible with ps/2 than with USB.

There is one more thing to try. Some mainboards and some programs might have some problem with the "num lock" and the numeric pad. Once you boot (with the KVM already connected to the system even before booting), if the normal cursor keys are not working, try changing the status of the "num lock". Then try again the "normal" cursor keys and the ones in the numeric pad ( 8 6 4 2 ).

If changing the "num lock" status doesn't work, change the BIOS setting of the "num lock on/off when booting", and try again the same procedure.

For each test, try booting from a complete "power off" status, instead of just resetting the system.


Top
 Profile  
 
 Post subject: Re: UBCD & KVM switch help
PostPosted: Tue Aug 23, 2011 5:07 am 
Offline

Joined: Mon Aug 22, 2011 8:30 am
Posts: 2
Thanks for your ideas piney and ady, I figured it out this morning. Apparently when the built in usb hub function was active on the unit booting UBCD there was a conflict with the motherboard usb bus and it was giving me peripheral device errors, oddly enough it doesn't do it on the other machine. I guess I can just chalk this one up to hardware not wanting to play nice together.

**I now have it working correctly with both machines.


Top
 Profile  
 
 Post subject: Re: UBCD & KVM switch help
PostPosted: Tue Aug 23, 2011 5:28 am 
Offline

Joined: Sat May 08, 2010 5:26 am
Posts: 750
minus2 wrote:
I now have it working correctly with both machines.

Would you mind sharing how you solved it?


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC - 8 hours


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group