Desktop Refuses to Boot

Try looking for help here if you are having problems with the latest beta of Ultimate Boot CD.

Moderators: Icecube, StopSpazzing

Post Reply
Posts: 1
Joined: Sun Sep 25, 2011 3:22 pm

Desktop Refuses to Boot

#1 Post by ToastyBiggins » Sun Sep 25, 2011 3:39 pm

Hi, I'm having a bizarre problem involving an unruly PC and the UBCD. Earlier today my desktop stopped booting, and I have no idea why. I'm running Windows 7 on a machine I built myself, MSI motherboard, SATA hard drive and CD drive, everything has worked perfectly until now. Then I get the dreaded "Reboot and select proper boot device". I open it up and everything looks fine, the BIOS is detecting the hard drive and the disk drive, but for some reason it won't boot from either of them. I tried the Windows 7 Recovery disk, thinking that maybe the boot sector on my hard drive had been corrupted somehow, but it didn't boot from that either. I double and triple checked the boot order to make sure it was reading from the CD drive, and in fact I could hear the disk spinning as it tried to read the disk, but there was literally no change, as if I had never put the disk in at all. And until very recently the disk drive was working, it's only three months old, and as far as I know nothing has happened that could cause it to become damaged or stop functioning. I know that the recovery disk wasn't at fault, because I was able to successfully boot my laptop (also running Windows 7) from the very same disk.

So, I decided to try the UBCD. It was the same as the Recovery Disk, there was no indication the disk was being read at all. "Reboot and select proper boot device, or Insert Boot Media in selected boot device and press a key." Again, I tested it on my laptop, and it booted, so I know that the disk burned successfully. But on the desktop, nothing. I don't think the problem is my hard drive, because isn't the UBCD supposed to work even if the hard drive is wrecked/nonexistent? The only thing I can think of is that the CD drive has become ruined somehow, although there are no signs of damage to it whatsoever, or some obscure problem with the BIOS is keeping it from recognizing boot disks, which is weird, because I used a boot disk to install Windows 7 in the first place not three months ago. I would test the CD drive if I could, but I don't have another computer available, and the one I have won't boot, so I'm not sure how I would check to see if it's broken.

Thanks for reading this long-winded request, I would really appreciate some help. I have a 15 page paper due on Tuesday and everything I have done so far is on that hard drive.

Posts: 826
Joined: Sat May 08, 2010 5:26 am

Re: Desktop Refuses to Boot

#2 Post by ady » Mon Sep 26, 2011 6:07 am

This topic doesn't belong to UBCD troubleshooting, but anyway...

If you *really* need the data in the HDD "immediately" (and you can't wait), then you need to take that HDD and connect it as a second HDD to another computer so to be sure that it is still readable. Don't boot with it in any other computer. Boot UBCD + PartedMagic to backup whatever you need.

That would be using a different computer, and if you can't wait.

Now, whatever happened to your current system, it seems that is not that much related to the specific HDD nor your optical drive, since no drive would boot.

So, unplug all your drives (HDD, optical, USB...) from both the data cable and the power cable of each. Then take out the CMOS battery, or, if you know where the reset cap is, use that.

For the battery reset jumper, keep it several seconds. The best practice though, IMHO, is to get the CMOS battery out for a couple of minutes (if you know how to do it without breaking anything).

Insert the CMOS/BIOS battery again (or remove the cap of the reset jumper), connect the power cable to your computer, but wait a couple of minutes before booting.

Still with no drive connected, boot into the BIOS and reset all values to "safe default". Save and reboot again into the BIOS.

Then change the BIOS to "optimal defaults", save and reboot again. Are the values being really saved? If the answer is "no", then you have your first clue.

If the values are saved, change back to "safe defaults" and save them. Reboot to confirm they were saved.

Now power off again the system and connect your optical drive only (both power and data cables). Boot into the BIOS, and configure it accordingly. The first boot might not recognize the drive, depending on the BIOS values (typically, LEGACY IDE, SATA, AHCI, RAID and USB values can prevent the BIOS from recognizing the drive). Save the correct values for your optical drive (SATA...) and reboot into the BIOS again. Does it recognize the optical drive?

Now insert UBCD and try booting with it (and no, your HDD is still not connected). Does it boot to UBCD?

Now power off again and repeat the procedure that you just did with the optical drive, but this time with the HDD. You can leave the optical drive connected too.

If the BIOS recognize both drives now, boot again UBCD. Success? Now try any "read-only" tool of UBCD / PartedMagic, so to check if the HDD is recognized.

If all the previous steps were successful, then try booting with your HDD as first booting device.

Good luck.

Post Reply