It is currently Fri Oct 24, 2014 8:15 pm

All times are UTC - 8 hours




Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 13 posts ] 
Author Message
 Post subject:
PostPosted: Sun Jan 21, 2007 11:24 am 
Offline

Joined: Thu Dec 21, 2006 4:28 pm
Posts: 85
I have Ubuntu on my multi-boot as well as other distro's, Windows and ,obviously, UBCD.

There are a number of ways you can boot (ED)Ubuntu from your CD.

The easiest way, however, is just to:

*Delete eveything from your isolinux folder provided with UBCD but keep cpustres and cpustres.gz (for lucifer)

*Copy everything from the (Ed)Ubuntu disc to the exact locations on your disc, appending the isolinux folder with the extra files.

*Add a line in CDShell some where like this:

Code:
if $lastKey == key[f1]; then isolinux


You can do more to reduce the size of the entire disc as you do not need all the folders contained on the (Ed)Ubuntu disc in order to boot from it.

Although, since your new to this I wanted to keep this simple for you!

If you do want some more reading on this then check out this topic over at MSFN.

I've posted some relevent info on adding liunx to CDShell here

Good luck.

-kof94


Top
 Profile  
 
 Post subject:
PostPosted: Fri Mar 14, 2008 1:24 pm 
Offline

Joined: Fri Mar 14, 2008 12:05 pm
Posts: 46
Location: United States
could you help me out im doing the exact same thing but i copys the entire contents of the ubuntu iso to ubcd but im not sure were you want me to add that command line...i tried your link but i didnt get any of it...could you run me through it here? im also planning on adding 2 other distros to the ubcd along with ubuntu for a total of 3 can you help me out with that? id like to be able to choose which of the 3 id like to install :)


Top
 Profile  
 
 Post subject:
PostPosted: Tue Mar 18, 2008 3:19 pm 
Offline

Joined: Thu Dec 21, 2006 4:28 pm
Posts: 85
Copy these dirs to the root of your disc:

/.disk
/casper
/pool
/preseed

...then copy the menu entries from the /isolinux/isolinux.cfg into your config file (/custom/custom.cfg if your using UBCD).

The entries look like this (taken from 7.10):

LABEL live
menu label ^Start or install Ubuntu
kernel /casper/vmlinuz
append file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.gz quiet splash --
LABEL xforcevesa
menu label Start Ubuntu in safe ^graphics mode
kernel /casper/vmlinuz
append file=/cdrom/preseed/ubuntu.seed boot=casper xforcevesa initrd=/casper/initrd.gz quiet splash --

Take a look at the config files in UBCD's /menus dir to get an idea of what your doing and /doc/menu.doc in the syslinux package (google syslinux).


Top
 Profile  
 
 Post subject:
PostPosted: Tue Mar 18, 2008 6:42 pm 
Offline

Joined: Fri Mar 14, 2008 12:05 pm
Posts: 46
Location: United States
ok thnx ill give it a try :) ill get back to ya :)


Top
 Profile  
 
 Post subject:
PostPosted: Wed Mar 19, 2008 9:27 am 
Offline

Joined: Fri Mar 14, 2008 12:05 pm
Posts: 46
Location: United States
it wont work

i get the following

Code:
Loading /casper/vmlinuz
         Loading /casper/intrid.gz

READY.
[23152.304017 isapnp checksum for device 1 is not valid (0x98)
[23152.304118 isapnp checksum for device 1 is not valid (0xbe)
Loading please wait....


and then nothing...any ideas?

NVM i rebooted and i got the same error but it loaded right up however my screen was scrambled....and when i try booting in safe graphics mode i get

[23152.304017 isapnp checksum for device 1 is not valid (0x98)

and it freezes any ideas?


Top
 Profile  
 
 Post subject:
PostPosted: Fri Mar 21, 2008 4:17 am 
Offline

Joined: Thu Dec 21, 2006 4:28 pm
Posts: 85
Does this happen with your original Ubuntu CD?


Top
 Profile  
 
 Post subject:
PostPosted: Fri Mar 21, 2008 11:09 am 
Offline

Joined: Fri Mar 14, 2008 12:05 pm
Posts: 46
Location: United States
no and i dont get this error with anything other than after i incorporate ubuntu..


Top
 Profile  
 
 Post subject:
PostPosted: Fri Mar 21, 2008 3:41 pm 
Offline

Joined: Thu Dec 21, 2006 4:28 pm
Posts: 85
It looks like the kernel is having problems identifying one of your devices but I have no idea what or why.

There is a file on the Ubuntu disk that shows the md5 checksums of all the files on the disk. Find the kernel (/casper/vmlinuz) and initrd (/casper/intrid.gz) and check them against the files your using and also check the .iso. If your a Linux user you can use md5sum for this, if your a Windows user google Hashtab.

What are you using to decompress and create the .iso images?


Top
 Profile  
 
 Post subject:
PostPosted: Mon Mar 24, 2008 7:10 pm 
Offline

Joined: Fri Mar 14, 2008 12:05 pm
Posts: 46
Location: United States
i fixed the problems it was nothing ubuntu worked fine i was using micorsoft virtual PC to test the iso and it seems it didnt like it...when using vmware or burning it and booting it it worked fine no problems

thanks for your help :)


Top
 Profile  
 
 Post subject:
PostPosted: Fri Mar 28, 2008 7:04 am 
Offline

Joined: Fri Mar 14, 2008 12:05 pm
Posts: 46
Location: United States
hey kof i tried starting the iso via vmware and it worked like a charm but when i burn the iso to a disk and try to start ubuntu i get an error that says the clock cant be sysnced and to try starting with the noapic command is their a way to add that to my custom.cfg so it will start with that command in place automatically?


Top
 Profile  
 
 Post subject:
PostPosted: Sat Mar 29, 2008 9:25 am 
Offline

Joined: Fri Jan 11, 2008 2:52 pm
Posts: 1278
Download the newest version of syslinux (contains also isolinux.bin).
http://syslinux.zytor.com
Replace all the files in your isolinux folder and syslinux folder that you can find in this archive. Add the following in your custom.cfg file.
Code:
LABEL ubuntu
  MENU LABEL ^Ubuntu
  CONFIG ubuntu.cfg

rename the isolinux.cfg file from the ubuntu iso to ubuntu.cfg and copy it to the isolinux (and the syslinux folder if you want to make a version for your usb memory stick). Copy also all the other files from the ubuntu isolinux folder to the ubcd isolinux folder.
The CONFIG command, will load the ubuntu.cfg file and isolinux will execute it, as it was the original cd (boot screen and all other options). This command is not available in the isolinux and syslinux version of the ubcd iso. If you want to make a bootable usb memory stick, use the syslinux program from the archive also and not the outdated version that ships with ubuntu. I tried this with another distro some months ago and it took me 3 days before I knew why my custom iso didn't work because I used an old version of isolinux.


Top
 Profile  
 
 Post subject:
PostPosted: Tue Feb 17, 2009 10:40 pm 
Offline

Joined: Tue Feb 17, 2009 10:21 pm
Posts: 1
Old topic, I know, just wanted to add my experience here since my solution differs, and because it took me so long to figure out.


I wanted Ubuntu (I used 8.10, the current one as of this post) and UBCD to boot from the same USB stick. I installed UBCD first (via this guide) and ensured it was bootable.

Next, following the tips in this thread, I copied all the files and folders from the contents of the Ubuntu ISO except for the /isolinux folder. I copied the contents of the Ubuntu /isolinux folder to my UBCD /syslinux folder, renaming the copied isolinux.cfg to /syslinux/ubuntu.cfg.

This was where I hit problems. Merely appending
Code:
LABEL ubuntu
  MENU LABEL ^Ubuntu
  CONFIG ubuntu.cfg
...as per Icecube's suggestion in this thread in my custom.cfg file would not boot! In fact, it didn't do anything; it simply sat there with the line selected. After toying around, my FINAL custom.cfg file looks like this:
Code:
MENU INCLUDE /menus/defaults.cfg
LABEL back
   MENU LABEL ..
   KERNEL menu.c32
   APPEND /menus/main.cfg
LABEL ubuntu
   MENU LABEL Ubuntu 8.10 LiveCD
   KERNEL menu.c32
   APPEND /syslinux/ubuntu.cfg

But this by itself is not quite enough! Syslinux would complain at me that the menu file I wanted to use had no LABEL arguments. I checked, and sure enough, it didn't, but it included a file (menu.cfg) that included a file (text.cfg) that had the relevant LABEL arguments to boot. So my solution was to replace the line "include text.cfg" (sans quotes) in menu.cfg with the entire contents of text.cfg, and then to replace the line "include menu.cfg" in ubuntu.cfg (formerly isolinux.cfg, remember) with the entire contents of menu.cfg, including the whole of text.cfg.

This may be a kludgy solution, but it works for me with no visible side effects (except that the Ubuntu boot menu uses the UBCD style... so what?). Ubuntu works just fine, and so does UBCD from all I've seen. Hope that helps someone!


Top
 Profile  
 
 Post subject:
PostPosted: Tue Feb 17, 2009 11:05 pm 
Offline

Joined: Fri Jan 11, 2008 2:52 pm
Posts: 1278
Quote:
This was where I hit problems. Merely appending
Code:
LABEL ubuntu
  MENU LABEL ^Ubuntu
  CONFIG ubuntu.cfg

...as per Icecube's suggestion in this thread in my custom.cfg file would not boot! In fact, it didn't do anything;

You need a more recent version of syslinux for this, than the one on UBCD411.

Ubuntu is difficult to integrate, if you want the same look as on the original CD because it uses a gfxboot patched version of isolinux.

Probably in the next version there will be a gfxboot comboot module for syslinux, so you can get the exact same menu as on the original Ubuntu CD.

_________________
Download Ultimate Boot CD v5.0: http://www.ultimatebootcd.com/download.html
Use Parted Magic for handling all partitioning task: http://partedmagic.com/


Top
 Profile  
 
Display posts from previous:  Sort by  
Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 13 posts ] 

All times are UTC - 8 hours


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group