It is currently Fri Aug 01, 2014 1:49 am

All times are UTC - 8 hours




Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: Parted Magic 3.2 is out
PostPosted: Sat Nov 29, 2008 1:31 pm 
Offline

Joined: Fri Jan 11, 2008 2:52 pm
Posts: 1278
Parted Magic 3.2 is out:
http://partedmagic.com/


Top
 Profile  
 
 Post subject:
PostPosted: Wed Dec 03, 2008 12:06 am 
Offline

Joined: Tue Dec 02, 2008 11:55 pm
Posts: 2
I am having trouble getting 3.2 to boot with grub4dos

I have a working 3.0 using this
Code:
title Parted Magic 3.0
find --set-root /boot/images/pmagic-svn.iso
map /boot/images/pmagic-svn.iso (hd32)
map --hook
root (hd32)
kernel (hd32)/pmagic/bzImage noapic root=/dev/ram0 init=/linuxrc keymap=us livecd vga=791 sleep=0 ramdisk_size=25000 noeject iso_location=/boot/images/pmagic-svn.iso
initrd (hd32)/pmagic/initrd


So I downloaded 3.2 and used this code
Code:
title Parted Magic 3.2
find --set-root /boot/images/pmagic-3.2.iso
map /boot/images/pmagic-3.2.iso (hd32)
map --hook
root (hd32)
kernel (hd32)/pmagic/bzImage noapic root=/dev/ram0 init=/linuxrc keymap=us livecd vga=791 sleep=0 ramdisk_size=25000 noeject iso_location=/boot/images/pmagic-3.2.iso
initrd (hd32)/pmagic/initrd


I can boot up and it will scan through usb, firewire, pcmcia etc, and right at the point where the Black X mouse cursor shows up I get a black screen and only the black X mouse cursor and it hangs.

So far I have tried these isos
pmagic-grub4dos-3.2.iso
pmagic-3.2.iso

And I am using grub4dos v0.4.4 2008-11-19

Dennis


Top
 Profile  
 
 Post subject:
PostPosted: Wed Dec 03, 2008 8:10 am 
Offline

Joined: Fri Jan 11, 2008 2:52 pm
Posts: 1278
How much RAM do you have? You need 300MB at least.

Try the alternate graphical server instead:
Quote:
title Parted Magic 3.2 (Alternate graphical server)
find --set-root /boot/images/pmagic-3.2.iso
map /boot/images/pmagic-3.2.iso (hd32)
map --hook
root (hd32)
kernel (hd32)/pmagic/bzImage noapic root=/dev/ram0 init=/linuxrc keymap=us livecd vga=791 sleep=0 ramdisk_size=25000 noeject xvesa iso_location=/boot/images/pmagic-3.2.iso
initrd (hd32)/pmagic/initrd


Or the Save Graphics settings:
Quote:
title Parted Magic 3.2 (Save Graphics)
find --set-root /boot/images/pmagic-3.2.iso
map /boot/images/pmagic-3.2.iso (hd32)
map --hook
root (hd32)
kernel (hd32)/pmagic/bzImage noapic root=/dev/ram0 init=/linuxrc keymap=us livecd vga=normal sleep=0 ramdisk_size=25000 noeject iso_location=/boot/images/pmagic-3.2.iso
initrd (hd32)/pmagic/initrd


Write down the error messages that you see.

You can also add the tmpfs_size=180M parameter to the commands and see if it makes any difference.

Did you add modules to Parted Magic, else you hve to increase the tmpfs_size parameter to 230M.


Top
 Profile  
 
 Post subject:
PostPosted: Wed Dec 03, 2008 1:27 pm 
Offline

Joined: Tue Dec 02, 2008 11:55 pm
Posts: 2
I have 4gb of ram.

I was able to get this to work using xvesa. I was not able to get it to work using xorg, no matter what settings I tried. This could be related to my system. I was testing this on a new Lenovo x200, I found an older desktop and xorg worked on that system.

I have not added any modules to this (do not know how) but am very interested in doing so. I have been testing and playing with small Linux versions (slax, puppy, and several others) and landed on puppy linux, currently around 125mb in size.

I run grub4dos and boot puppy off my usb drive, but since playing with parted magic, it is much better. The only thing preventing me from using parted magic as my usb small Linux is I need to learn how to save changes and add and update modules.

Right now puppy saves changes real easy and I can update it, but cannot get it to detect my network or wireless on my new Lenovo x200.

parted magic finds and works with my wired and wireless network on this new box.

Dennis


Top
 Profile  
 
 Post subject:
PostPosted: Wed Dec 03, 2008 2:08 pm 
Offline

Joined: Fri Jan 11, 2008 2:52 pm
Posts: 1278
dlevens wrote:
I was not able to get it to work using xorg, no matter what settings I tried. This could be related to my system. I was testing this on a new Lenovo x200.

Post it at http://forums.partedmagic.com with more information about your hardware. Not sure if if will be solved.
dlevens wrote:
I have not added any modules to this (do not know how) but am very interested in doing so.
I run grub4dos and boot puppy off my usb drive, but since playing with parted magic, it is much better. The only thing preventing me from using parted magic as my usb small Linux is I need to learn how to save changes and add and update modules.

There is an option in Parted Magic to save the changes. Save the changes before you add modules, else you don't need the modules the next time you boot because they are then in the /pmagic/pmodules/pmagic.7z file. You can add modules to the /pmagic/pmodules directory.
http://downloads.partedmagic.com/modules/
http://www.ultimatebootcd.com/forums/viewtopic.php?t=1361


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC - 8 hours


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group