It is currently Tue Nov 25, 2014 9:22 pm

All times are UTC - 8 hours




Post new topic Reply to topic  [ 8 posts ] 
Author Message
 Post subject: Impossible to use HDD Diagnose
PostPosted: Sun Feb 15, 2009 8:43 am 
Offline

Joined: Sun Apr 15, 2007 5:28 am
Posts: 8
Location: France
First, excuse me for my english, because i am French.

I am a faithful user of UBCD since 5 years, and i customize it for
my personnal use.

With older and recent PC platforms, there is any problem with the
utilisation of UBCD V5.

With newer PC platforms, Notebook or Desktop, it is impossible to
diagnose HDD. Test is impossible with CD version, USB version, and also
with version b11 patched for Grub4Dos.

If you have a chipset with parameter SATA as IDE, UBCD run very well.
If you have a chipset HDD Sata and CD Sata, when you want to run DFT,
the programm loading stop at the text LOADING DFT.
Seatools lauch correctly, but no hard drive detected.
Hdat2 no detect hard drive.
Vivard dont load correctly with an CD error code about "***.bat"

My observations are :
In the Bios parameters, the CDRom is not in CDRom drive but in
Optiarc CD Drive.
When you use a Vista PE, No phisycal HDD present in the Explorer.

The problem is present for theses platforms :
TOSHIBA : Newer Notebooks
PBell : Newer Desktops
HEWLETT & COMPAQ : Newer Desktops and Notebooks
ACER : Newer Desktops.
FUJISTU-SIEMENS : Newer Notebooks

Also if you use PartedMagic, it is impossible to mount the physical HDD
off your computer, besause it is not present in the explorer.

It is difficult to understand where is the problem, besause the computer
run, and it is possible to restore it with the DVD Masters.

I hope i am not the one who have this problem, but the first who
say you about this.

beforehand thank you

Important precision, memory test is running correctly with Newer computer with all versions off UBCD V5


Top
 Profile  
 
 Post subject:
PostPosted: Mon Feb 16, 2009 12:42 pm 
Offline

Joined: Fri Jan 11, 2008 2:52 pm
Posts: 1278
Can you find the devices with Parted Magic?
- Start ==> Accessories ==> Hardware Lister
- Smart control

Also try Parted Magic 3.6 (there was a problem for detecting certain CD drives in v3.5).

_________________
Download Ultimate Boot CD v5.0: http://www.ultimatebootcd.com/download.html
Use Parted Magic for handling all partitioning task: http://partedmagic.com/


Top
 Profile  
 
 Post subject:
PostPosted: Mon Feb 16, 2009 1:39 pm 
Offline

Joined: Sun Apr 15, 2007 5:28 am
Posts: 8
Location: France
thank you for your reply

I download PartedMagic 3.6, i burn it and i will test it tomorrow
on differents platforms.

Tomorrow evening i bring back to you the observations


Top
 Profile  
 
 Post subject:
PostPosted: Tue Feb 17, 2009 12:55 pm 
Offline

Joined: Sun Apr 15, 2007 5:28 am
Posts: 8
Location: France
I download PartedMagic v3.6 and i made a bootable CD.

PartedMagic is running well on itself, but on the newer computer
i have today, no hard drive detected. No Hda no Sda visible inside
the computer.

I have better results with Drive Fitness v4.15 only on a bootable
CD or FDD than DFT incorporate in UBCD v5b10, but it is not
universal because stop loading on a number restricted of computer

I continue my inquiry and i will report you my observations


Top
 Profile  
 
 Post subject:
PostPosted: Wed Feb 18, 2009 1:38 pm 
Offline

Joined: Sun Apr 15, 2007 5:28 am
Posts: 8
Location: France
Today, i have a solution for only one NEC desktop.

I am going in the bios, and in
Integrated peripherals i put the SATA operation mode on IDE
Originally the regulation is on AHCI
and all tests are running well

But in Notebook Bios which not have Possibilities of regulation of the AHCI I am blocked.

Tomorrow i test another Builder desktop

Just a question
Think you one day make compatible UBCD v5 with AHCI?


Top
 Profile  
 
 Post subject:
PostPosted: Thu Feb 19, 2009 2:19 pm 
Offline

Joined: Sun Apr 15, 2007 5:28 am
Posts: 8
Location: France
I have a confirmation

Today i test a ACER Desktop
HDD test was impossible

In the MotherBoard Bios, i change in SATA MODE SELECT
original value in AHCI MODE by SATA MODE
and DIAGNOSES - HDD - UBCD v5b10 running well

It is really the compatibility of UBCD with the AHCI which is in question :oops:


Top
 Profile  
 
 Post subject:
PostPosted: Thu Mar 05, 2009 8:29 am 
Offline

Joined: Fri Jan 11, 2008 2:52 pm
Posts: 1278
Read: http://en.wikipedia.org/wiki/Advanced_Host_Controller_Interface

Quote:
* The AHCI controller does not work on AMD/ATI RS400-200, and RS480 HBA; and Nvidia nForce 560 chipset[citation needed] when MSI is enabled due to a hardware error. In order for AHCI to work users must provide the "pci=nomsi" kernel boot parameter. With MSI disabled in this way, the PCIe bus can only act as a faster PCI bus with hotplug capabilities.
* The AHCI controller on AMD/ATI SB600 HBA can't do 64-bit DMA transfers. 64-bit addressing is optional in AHCI 1.1 and the chip claims it can do them, but, in reality, it can't so it is disabled. After that it will be forced to do 32-bit DMA transfers. Thus DMA transfers will occur in the lower 4 GiB region of the memory, and bounce buffers must be used sometimes if there is more than 4 GiB of RAM.[9]
* The VIA VT8251 South bridge suffers the same fate but it can be circumvented with the "pci=nomsi" option to force detection of the chip. This has been tested to work on 2.6.26, 2.6.24 and 2.6.20 kernels.
* Under RHEL, CentOS and similar, if you change your BIOS to AHCI mode and do not have the ahci drivers in your initrd then you will not be able to boot. To solve this
o Set you BIOS to IDE/ATA/Original setting mode
o boot into linux
o edit /etc/modprobe.conf and add the line alias scsi_hostadapter2 ahci
o run mkinitrd -f /boot/initrd-`uname -r`.img `uname -r`
o reboot in to you BIOS and set to AHCI/RAID mode
o boot into linux
o check your vendors manual for more details


Are you affected by something that is listed on that page?

_________________
Download Ultimate Boot CD v5.0: http://www.ultimatebootcd.com/download.html
Use Parted Magic for handling all partitioning task: http://partedmagic.com/


Top
 Profile  
 
 Post subject:
PostPosted: Sat Mar 07, 2009 6:08 pm 
Offline

Joined: Sun Apr 15, 2007 5:28 am
Posts: 8
Location: France
Thank you for your reply

I test that next week and send you the result


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 8 posts ] 

All times are UTC - 8 hours


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group