UBCD2USB broken, need a hand!

Try looking for help here if you are having problems with the Ultimate Boot CD.

Moderators: Icecube, StopSpazzing

Posts: 3
Joined: Sat Nov 28, 2009 1:23 pm

UBCD2USB broken, need a hand!

#1 Post by archont » Sat Nov 28, 2009 1:29 pm

Here's the message I get:
G:\tools\ubcd2usb>ubcd2usb G:\ F: -Y -D 1

UBCD2USB: Creating bootable UBCD memory stick ...
UBCD2USB: Launching 'makebootfat' to format USB drive
device_start 0 [sectors]
device_size 1994752 [sectors], 974 [MB]
device_geometry 974/64/32 [cylinders/heads/sectors] (ZIP-Drive compatible)
bios_drive HDD
Error 87 reading the device.

(ERROR) 'makebootfat.exe' failed

Aby kontynuować, naciśnij dowolny klawisz . . .
Running on XP with full administrative privilidges. G:\ is path to the virtual daemon drive on which I mounted the UBCD iso. Alhough I tried G:, g:, G:\, G:/, g:/, g:\, g and G..

F is the drive of the USB drive, although I also did try f:, f, f:/, f:\, F:/, F:\ and so on.

Checking the drive manager in windows' control panel shows the usb is drive number 1. That shouldn't be required, as the drive is the ONLY usb drive on the system.

How do I fix this damned broken thing?

Cheers, and I'd be grateful for anyone giving a hand.

Posts: 3
Joined: Sat Nov 28, 2009 1:23 pm

#2 Post by archont » Sat Nov 28, 2009 1:32 pm

Worth noting is that I tried formatting the drive to both FAT32 and FAT (FAT16).

Also I tried using the utility without the -D switch.

Neither option was fruitful.

Posts: 3
Joined: Sat Nov 28, 2009 1:23 pm

#3 Post by archont » Sun Nov 29, 2009 2:36 am

I'm still struggling with this. And while the error is obviously in makebootfat, there's no documentation for the damned thing. Error 87 doesn't tell me much.

Posts: 1278
Joined: Fri Jan 11, 2008 2:52 pm

#4 Post by Icecube » Sun Nov 29, 2009 5:01 am

Can you try UBCD50RC1?
Download Ultimate Boot CD v5.0: http://www.ultimatebootcd.com/download.html
Use Parted Magic for handling all partitioning task: http://partedmagic.com/

Posts: 4
Joined: Sun Nov 29, 2009 3:25 pm

#5 Post by jackmcguire99 » Mon Nov 30, 2009 4:23 am

I managed to use ubcd2usb.bat for UBCD v4.1.1 last Sunday.

The main difference in my set up was that I extracted the ISO to my hard drive using 7zip.

I found out that ubcd2usb doesn't like spaces in the filename path, eg C:\Documents and Settings\Some User\etc won't work. So I made sure the top level directory of the extracted files was at the root of my C drive.

It was necessary for me to look inside ubcd2usb.bat to make sure I was handing it the proper path name. Looking at the bat file might help your problem too?

Maybe try extracting the files to your hard drive - you can always delete them afterwards - and run ubcd2usb.bat from your hard drive.

Hope this might help