UBCD and Photorec _ Can not see another destination Disk

Try looking for help here if you are having problems with the latest beta of Ultimate Boot CD.

Moderators: Icecube, StopSpazzing

Post Reply
Message
Author
fab475
Posts: 1
Joined: Thu Feb 12, 2015 4:59 am

UBCD and Photorec _ Can not see another destination Disk

#1 Post by fab475 » Thu Feb 12, 2015 5:20 am

Hi,

I tried to restore files with photo rec.
Cd booting, i choose /HDD/Data Recovery and photorec and Enter.

Graphical interface run. I choose dos Photorec in menu.

In photo rec i can see all disks and all partitions.
I choose the partition to find files to restore.
When it ask me where to save file;, Now, i see i think only the folders of Ubcd ; all other driver no find.

Do you Know How see other disk and choose .?

In advance thx for help and very sorry for english.

brougham
Posts: 1
Joined: Fri Aug 28, 2015 7:57 pm

Re: UBCD and Photorec _ Can not see another destination Dis

#2 Post by brougham » Fri Aug 28, 2015 7:59 pm

I am having the exact same problem, I cannot see a valid destination drive for the recovery. I am only able to see the root of the RAM drive of parted magic.

Does anyone know a solution to this? Or how to successfully recover using Photorec inside Parted MAgic.

Thank you

The Piney
Posts: 354
Joined: Mon Apr 30, 2007 11:06 am
Location: FL

Re: UBCD and Photorec _ Can not see another destination Dis

#3 Post by The Piney » Sun Aug 30, 2015 1:41 am

I had the same issue with testdisk/photorec a couple years back.

I ran testdisk/photorec with "sudo" and it worked fine.
In terminal, type "sudo photorec" and type in the password when asked.

Good luck.

AzimuthSpace
Posts: 1
Joined: Tue Dec 03, 2019 1:35 pm

SOLUTION: Re: UBCD and Photorec _ Can not see another destination Disk

#4 Post by AzimuthSpace » Tue Dec 03, 2019 4:25 pm

This thread returned by Google's first page search results for the search terms: "Ultimate Boot CD Photorec"

I didn't see any comprehensive answer returned by Google Search results so here is MY total solution for the LAYMAN trouble-shooter:

1. Once you have Parted Magic loaded, ensure that your external HDD or USB is "mounted" or activated within the program. Navigate to the bottom left of Parted Magic's main interface and click the second button from the left called "Parted Magic Mount". I had to identify my external storage media by the storage capacity and filesystem type. Click the green "Mount" button to make the media findable by the PhotoRec tool. BUT WAIT...

2. Ensure your external storage media is not mounted as "Read-only" If it is mounted thusly, there will be a check-mark in the box beside the "Read-only" option placed just beside the green "Mount" button. If your volume is mounted as "Read-only", this means that the device is in a "protect mode" of sorts and PhotoRec will not be able to write the recovered files to your media.

To remove "Read-only" status from your external media go to your command terminal (ROXTerm) which is the third button on the bottom left. Type in:
sudo apt-get remove ntfsprogs && sudo apt-get install ntfs-3g
and restart your system to boot back up to UBCD and Parted Magic

OR (if that doesn't work)

Find the label of your external drive listed in second column of information in the Parted Magic Mount menu. For example, my drive label in PM is: /dev/sdd1
Type in the following command into ROXTerm command terminal (where x is HDD and X is drive number):
sudo ntfsfix /dev/sdxX
Then restart your system after executing. One of these two solutions should work. In my case, this second solution was sufficient.

3. Lastly, once you're in PhotoRec, you'll end up at the phase of locating your external storage media through the ROXTerm console menu provided. The previous steps should ensure that our media will show up somewhere. You can locate you media in one of these locations:
File system from external disk may be available in a /media, /mnt or /run/media sub-directory. Mount your destination drive if necessary
Following the steps above solved my issue and will hopefully do the same for any frustrated Google-Searcher or troubleshooting layman. I'm not a regular on this forum, I just made an account to fill in some information where there seemed to be a comprehensive gap. I encourage other kindred netizens to do the same when they seen a need somewhere on this vast web. Good luck.

Post Reply