UBCD on a USB Flash Disk (USB Key)

Post your suggestions here if there are new features or applications that you would like added to the Ultimate Boot CD.

Moderators: Icecube, StopSpazzing

Do you think UBCD on a USB Flash Disk is...

No votes
I don't care (it would just be another gadget)
Total votes: 76

Posts: 2
Joined: Tue Apr 03, 2007 5:48 am

#101 Post by face » Wed Apr 04, 2007 1:07 am

To your information:

The USB Stick boots on my home PC, but not at my PC at work. The BIOS settings are the same. first boot = USB Floppy

Posts: 2
Joined: Sat May 05, 2007 6:28 am

UBCD on 256 Mo key

#102 Post by enlivraison » Sat May 05, 2007 7:25 am


sorry for my english :(

1.With my USB Key 256 :

c:\ubcd\tools\ubcd2usb>ubcd2usb.bat c: g:

UBCD2USB: Creating bootable UBCD memory stick ...
Press any key to continue, press ESC to abort
Press any key to continue, press ESC to abort
UBCD2USB: Launching 'makebootfat' to format USB drive
device_start 0 [sectors]
device_size 501760 [sectors], 245 [MB]
device_geometry 245/64/32 [cylinders/heads/sectors] (ZIP-Drive compatible)
bios_drive HDD
fat_start 32 [sectors]
fat_size 501728 [sectors]
fat_bit 32
fat_sectorpercluster 4
write 794624 [sectors], 388 [MB] Disk Full
[ERROR] 'makebootfat.exe' failed
Appuyez sur une touche pour continuer...

It just mean that my USBKEY has not enough capacity ?

2. I want to include in UBCD sysclean.com and update definitions virus with a ".bat"

3. I want to include ghost 8 with many dos drivers for many network card
(I have licences)

4 .I was be able to boot on this key on many compatible workstation and laptop and choose to launch UBCD or Ghost...

Thanks for all your job !!!!!!!

Posts: 4
Joined: Sun Mar 25, 2007 11:00 pm

#103 Post by Seanster » Sat May 05, 2007 8:16 am

Here's a summary of the differences between your failed attempt any my successful attempt:

501760 [sectors], 245 [MB]
fat_size 501728 [sectors]
fat_sectorpercluster 4
write 794624 [sectors], 388 [MB] Disk Full
[ERROR] 'makebootfat.exe' failed

1003520 [sectors], 490 [MB]
fat_size 1003488 [sectors]
fat_sectorpercluster 8
write 245760 [sectors], 120 [MB]

Why would it attempt to write 388 MB when it is only 120?

I hope that helps someone figure this out.

Posts: 4
Joined: Sun Mar 25, 2007 11:00 pm

#104 Post by Seanster » Sat May 05, 2007 8:35 am

You should try the beta version of makebootfat. Get it here:

http://advancemame.sourceforge.net/beta ... entium.zip

Please let us know if it works.


Posts: 2
Joined: Sat May 05, 2007 6:28 am

Ghost and Sysclean

#105 Post by enlivraison » Sun May 06, 2007 3:20 am


It worked fine on my Kingston DataTraveler II 256m stick, after format with Windows and use makebootfat (the old, not your's....I don't understand anything about it....But, finally, it works, so, thanks for all !!!)

But I have other questions:

I want to include Ghost8 and Sysclean.com (http://uk.trendmicro-europe.com/enterpr ... rt/tsc.php) in the menu...



Posts: 2
Joined: Wed Aug 29, 2007 4:48 pm

#106 Post by jordan » Wed Aug 29, 2007 5:04 pm

It shows some errors when cycling through the different drives, but it properly identifies B: as the UBCD drive. :roll:

Posts: 2
Joined: Thu Sep 13, 2007 4:22 am

#107 Post by Grou » Thu Sep 13, 2007 5:08 am

Hi everybody,

I've carefully followed everything written in this post, and finally managed to create an USB bottable UBCD. However, besides the work done by yours guys is great, I encountered a problem that other people should have too.

When launching the ubcd2usb.bat, I had the folowing message :

Code: Select all

UBCD2USB : Launching 'makebootfat' to format USB drive
Please insert ONLY ONE usb disk
UBCD At this point you migth want ... to refresh system's view of its content
<ERROR> Missing 'f:\ldlinux.sys' (Where is USB-drive?)
I focused on the last error message and i understood the first one latter when trying to launch the makebootfat stand alone.

1st remark : the 'Please insert ONLY ONE usb disk' doesn't sound like a 'beware buddy it doesn't going to work that way' moreover the program continues as if nothing happened

I had this error due to the presence of several SD-card-like drives of my floppy drive, I inactivated them from windows XP (i could have simply unplugged them too). Once all the unrelevant drives have been inactivated the procedure worked perfectly.

Finally i just wanted to explain the problems I had and hopefully some adjustement concerning warning/error messages in the next ubcd releases (4.1.2 and upper) should warn other newbies like me :D that beside giving a precise drive letter (f: ) makebootfat doesn't like to express itself in front of other flash drives (g: h: )....it is indecent.

Hoppin it will be usefull for somebody

PS : I'm french so excuse my poor english.

Jackal von ÖRF
Posts: 1
Joined: Fri Sep 14, 2007 12:33 am

#108 Post by Jackal von ÖRF » Fri Sep 14, 2007 12:37 am

I have a problem in booting UBCD 4.1.1 from a USB memory stick. I used ubcd2usb.bat to prepare the stick, but when booting it gives the following error:

Could not find kernel image: linux

Please help me.

Posts: 2
Joined: Thu Sep 13, 2007 4:22 am

#109 Post by Grou » Sat Sep 15, 2007 2:58 am

To Jackal von ÖRF :

Unfortunately it seems that you did not carefully read the previous posts since limerik had exactly the same error message. Have you tried every solution proposed by the other guys ?

You should check the UBCD2USBfdd.cmd (read previous messages, you'll find the link to download it) and check the boot sector of your USB key with PTEDIT (again quoted in the previous messages, page 3 or 4 i think)

If you've tried everything maybe you should give us more information concerning what you have done (content of you key, etc...)

Posts: 1
Joined: Fri Sep 21, 2007 10:08 am

#110 Post by MrWolf » Fri Sep 21, 2007 10:21 am


I tried to install UBCD on my kingston usb key like everyone :P

I fallow all the step but each time I boot I get this:

Code: Select all

SYSLINUX 3.51 ... Copyright (C) .... H. Peter Anvin
Could not find kernel image : linux
boot :
in my bios I can see my usb key like you can see:


can anyone help me through this to make it work?

Posts: 1
Joined: Mon Sep 24, 2007 11:05 pm

#111 Post by CrazyFoool » Mon Sep 24, 2007 11:08 pm

EDIT: Figured it out.

Posts: 5
Joined: Fri Oct 26, 2007 2:17 am

#112 Post by yantei » Fri Oct 26, 2007 10:11 am

i couldn't install ubcd on my usb stick using ubcd2usb script from 4.1.1 (i had Could not find kernel image: linux error)

makebootfat -v -o %DEVNAME% -Z -Y -F -b ldlinux.bss -m mbrfat.bin -c "%1\syslinux\ldlinux.sys" -x "%1\boot.catalog" %1

this code finally worked for me
(edit the ubcd2usb.bat file)
mbrfat.bin taken from old reblu's ubcd2usb package

Posts: 5
Joined: Fri Oct 26, 2007 2:17 am

#113 Post by yantei » Sun Oct 28, 2007 2:41 am

I found out, that I can't copy any data to this stick, because booting from it stops working after this operation...

Is that true?

Posts: 2
Joined: Wed Dec 26, 2007 10:28 pm

#114 Post by rola » Thu Dec 27, 2007 7:35 pm

yantei wrote:I found out, that I can't copy any data to this stick, because booting from it stops working after this operation...

Is that true?
I have the same question.

Posts: 1
Joined: Sat Mar 01, 2008 9:27 am

#115 Post by syntaxer » Sat Mar 01, 2008 9:41 am

hi, i'd the same problem as some of you: Could not find kernel image: linux

i found a working solution.

1) format your usb stick with fat (i'd prefer fat16)
2) Download syslinux and start syslinux\win32\syslinux.exe e: (where e: is the driveletter of your usb stick)
3) copy from ubcd the files from the \syslinux directory to the root of your usb stick (except: ldlinux.sys)
4) copy now the all the files and directories from ubcd to the root of your usb stick

this was working fine for me, and did not get the ugly: Could not find kernel image: linux error message anymore

Posts: 9
Joined: Sun Jan 06, 2008 8:34 pm

#116 Post by richk » Wed Apr 30, 2008 12:56 pm

This latest approach still doesn't allow dos applications (like drive fitmess test) to run.

Posts: 2
Joined: Wed Jun 18, 2008 2:54 pm

Solution to Error 21

#117 Post by server_sovereign » Wed Jun 18, 2008 6:20 pm

I was getting an Error 21 (unable to write to device) error using the makebootfat.exe that came with UBCD. I solved the problem by dropping in a newer version of makebootfat.exe that I found here:

http://advancemame.sourceforge.net/beta ... entium.zip

I had to run ubcd2usb.bat twice before it worked. Just thought I'd post my success in case anyone else was getting this error.

Posts: 1
Joined: Thu Nov 06, 2008 5:57 am

Ultimate Tortural!!!

#118 Post by Hansihe » Thu Nov 06, 2008 6:01 am

Posts: 1
Joined: Mon Nov 10, 2008 12:52 pm

Running UBCD V50b5 on USB flash key

#119 Post by mafj » Mon Nov 10, 2008 1:06 pm

To run UBCD v5 from usb flash key:

As Hansihe mentioned follow the steps on Tortural at PenDriveLinux.com Tortural at PenDriveLinux.com.

If you find it does not work (as I found it problematic):
Follow the instructions of syntaxer,. that is:
Download syslinux package
On your USB drive: overwirte x:\*.* files with files from x:\syslinux\
From syslinux package take just win32 folder, with witch replace x:\syslinux\win32.
run x:\syslinux\win32\syslinux x:

and you are done. your image will boot and you will get proper menu displayed.

Posts: 9
Joined: Tue May 20, 2008 6:46 pm

#120 Post by pio » Wed Dec 24, 2008 3:56 pm

My opinion on that is:
If I can boot from USB why should I boot from CD?

The only reason I see
- no USB port (USB addon cards are cheap)
- USB booting not supported by BIOS, ok, this is really bad, but here are workarrounds (minimal kicker cd with USB drivers and plop bootmanager)

I go so far and say "it would be cool if Ultimate Boot CD would be renamed into Ultimate Boot USB".