Help me: Blank Screen, Ultimate Boot CD will not load

Talk about anything related to the UBCD, PC troubleshooting etc.

Moderators: Icecube, StopSpazzing

Post Reply
Message
Author
ledongchieu8
Posts: 1
Joined: Sun Sep 09, 2018 7:59 pm

Help me: Blank Screen, Ultimate Boot CD will not load

#1 Post by ledongchieu8 » Sun Sep 09, 2018 8:01 pm

Hi everyone!
I have a desktop PC that will not boot up. It has been working for years but the last time I started it all I got was a blank screen. I tried started it in Safe Mode but I still get a blank screen. I tried starting it to the BIOS but all I get is a blank screen. I tested the battery at 3.2 volts. I reseated all connections to drives. I took out memory cards and tried them one at a time but nothing makes any difference. I downloaded Ultimate Boot CD and burned the ISO file to a CD. The CD works in a laptop but all I get is a blank screen on the desktop. I plugged the monitor into my desktop and it works on the laptop. The desktop has the CD drive in the startup before the hard drive. I have run been able to run Linux in the past from a bootable CD but not now. When I power on the PC I do not get any beeps but the fans come on and the harddisk light stays on for about a minute and then goes off. I have searched this board but I could not find a hit. Any suggestions?

thank!

The Piney
Posts: 341
Joined: Mon Apr 30, 2007 11:06 am
Location: FL

Re: Help me: Blank Screen, Ultimate Boot CD will not load

#2 Post by The Piney » Tue Sep 11, 2018 11:12 pm

First off - Check the video/monitor cable connections if you haven't. Then --->

I usually start by disconnecting all non-essential devices/parts like HDDs, USB devices, etc just to see if you can get to BIOS/Setup. Only leave Motherboard, Processor, Ram and Video card (if you have one). If you have onboard video and a card, disconnect the card as well and connect monitor to the onboard. If it doesn't get you to BIOS at that point fewer parts makes it easier to diagnose. If you have a known-good power supply and/or other parts you can try swapping them out.

Hope that helps

Post Reply